[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Mouse doesn't work on iBook G4 after sleep in Sid

On Sat, May 10 2008, at 10:26 +0200, Denís Fernández Cabrera wrote:
> Hello all, and sorry for reviving this old thread.

As you address more than just me, I'll try to CC the Debian powerpc
list ... I hope this is OK ... :) - for this to work I changed the
"In-Reply-To" header in this email ... let's see how lucky I am with it
... :) ... 

And Sorry if this isn't exactly the standard way ...

> I've just recently dist-upgraded again, and installed the 2.5.25-1
> kernel in my iBook G4 (mid 2005):
> denis@sputnik:~$ uname -a
> Linux sputnik 2.6.25-1-powerpc #1 Mon Apr 28 15:21:27 UTC 2008 ppc GNU/Linux
> The appletouch bug is still there. Has anybody found a way around it,
> or a way to fix it?
> Wolfgang: Sorry for not trying your kernel back then --- i got tangled
> in busy life, and since the older kernel (2.6.18-5) worked more or
> less fine (the wifi worked just barely, and that is what gets me
> trying to make the switch to 2.6.25) I kept going on it.
> Could you upload the kernel again somewhere? I'll give it a try.

See here:

The one linked to from the message above should be the latest one I
uploaded, IIRC ..

> Also: Have you noticed other mouse freezes after the one you mentioned here?

I see with my current 2.6.25-rc3 the mouse disappear on an old
ti-book. Never, IIRC, on a newer alubook 5,8.

If you're already at it, why not trying to compile the latest git
sources? It should be easy after - possibly (?) - solving the package
dependencies for linux-image builds ... Mini HOWTO ... :) ... : 


$ cd kernel-factory/git/
$ git clone git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git

$ ls
.  ..  linux-2.6

# Keep it up-to-date:
$ cd linux-2.6/
$ git pull

## Have a nice view on the kernel:

$ gitk --all &

## The compile, something like

time MAKEFLAGS="CC=gcc-1.23"  fakeroot make-kpkg --append-to-version=-abcd1234 --revision=1234.56.78 kernel_image

You'll find a .config  - about 2 months old or so - via the mailing
list URL above ...

Good luck!


Reply to: