[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Issues with Debian Lenny on Powerbook G4

Hey everyone,

I recently upgraded the hard drive of my laptop and decided to take the chance 
and plunge to lenny. I had Etch running beautifully on this laptop.

The lenny experience started out beautifully but there are several issues I came 
across with:

 1. Xorg.conf
   * No matter what I tried I couldn't get X to start. The furthest I have gone is 
with X starting but I get a blank black screen.
   * I even used the old xorg.conf from my etch machine but it didn't work either.

 2. Power management/laptop mode
   * I installed laptop-mode tools and pbbuttonsd just like I did when I had etch. 
This installed apm and I was used to invoking 'apm' at the command prompt to 
get the battery status. However, with Lenny I get the error message that the 
kernel does not support apm.

   * I understand powerbook uses pmu so I tried installing that but it conflicts 
with the already installed laptop-mode-tools.

I installed using debian lenny installer beta 1 netinst.

Laptop Specs:

 - Powerbook G4 Titanium 500MHz G4, 512MB RAM.

I need some help here...


Reply to: