[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

getting wireless and dvi out (clone mode) to work on iBook G4 - help needed, plz



Hello list,

Greetings. I am a debian user since few years now. But relatively a
new linux-on-powerpc user. I hope my questions are appropriate to this
list, otherwise plz let me know. My current setup:

Machine: iBook G4:
$ cat /proc/cpuinfo
processor       : 0
cpu             : 7447A, altivec supported
clock           : 1199.999000MHz
revision        : 0.2 (pvr 8003 0102)
bogomips        : 73.47
timebase        : 18432000
platform        : PowerMac
machine         : PowerBook6,5
motherboard     : PowerBook6,5 MacRISC3 Power Macintosh
detected as     : 287 (iBook G4)
pmac flags      : 0000001b
L2 cache        : 512K unified
pmac-generation : NewWorld

OS       : Etch 4.0r1 (2.6.18-5) dual booted with OSX 10.3.9
Does not work -[1]- DVI out (clone mode) to external projector
                          -[2]- wireless (using bcm43xx-fwcutter?)
Partially works -[3]- suspend-to-ram using Gnome when closing the lid
Cannot verify   -[4]- modem to connect over a telephone line (don't
care for this, as of now)

What I am hoping to achieve (with help from this list): working [1]
and [2] - really need them, not so much for [3] and [4] - can do
without them.

Ok, now to the details... I have tried Kubuntu (7.04, 7.10), openSUSE
10.3, Debian Lenny on this machine: [2] works (both WEP and WPA enc
networks) on Kubuntu 7.10, [1], [2] (WEP only) & [3] (using KDE's
kpowersave) works on Kubuntu 7.04, [1] partially worked on suse. I
could never get a satisfactory state for [1] and [2] on the same
installation. Both Kubuntu and openSUSE are bloated and slow, in
contrast, Etch is sufficiently snappy.

So here are the questions:
1. Is it possible to achieve [1] and [2] (for WPA enc) on Etch (may be
using backports too) or do I have to break my system to a hochpoch of
testing-unstable-experimental? I was browsing the list and saw a few
threads on new ati/radeon driver, appletouch, etc...
2. If so (or otherwise) any pointers (links to older threads/fresh
comments) on how to achieve them?

It is not that I haven't dirtied my fingers, but just that I don't
have much time now to handle a testing-unstable-experimental mix.
Also, I have already tried few things to get [1],[2],[3] working and
failed at one or the other...

Btw, (is this a bug?) the default installation of bcm43xx-fwcutter
tries to download the firmware (wl_aspta.o) from
http://boredklink.googlepages.com/wl_aspta.o which doesn't exist
anymore (may be it existed earlier). It can be obtained from
http://xeve.de/down/wl_aspta.o (got this from Kubuntu 7.10) - which I
used to cut the firmwares - so that the hardware is recognized but
neiter works on WEP nor WPA networks.

Similarly, I have tried different configurations for xorg.conf (from
other distros and general googling) to mirror the LCD screen to a
projector in clone mode - no results, hence I am here.

Any help is much appreciated guys. And it feels good to see that
Debian developers are eager to keep the ppc port moving ahead, unlike
other distros (fedora, ubunutu, suse, mandriva) which are neglecting
it and have either discarded it already already will do so soon.

-- 
Regards
PK
--------------------------------------
http://counter.li.org  #402424



Reply to: