[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing Debian on a Beige G3 PowerMac (OldWorld)

On 03/01/2007, at 6:31:59PM, Dana Sibera wrote:

On 01/01/2007, at 5:16:30PM, Rick Thomas wrote:

Are you interested in installing using the BootX with OS9 bootloader? If so, please read the BootX documentation that comes with the BootX package and at http://penguinppc.org/bootloaders/ bootx/ . Then download and burn a recent "businesscard" or "netinst" CD from http://cdimage.debian.org/cdimage/daily-builds/ daily/arch-latest/powerpc/iso-cd/ . Then get back to me and I'll help you walk thru the process. The same steps should work on any or all of the boxes you mentioned, but I recommend starting with the beige G3 as it will probably have the fewest "gotcha"s.

I'm mostly interested in getting the machine running reliably any way it can for my webserver, and have used BootX in the past (this was on the 6360-6500 and other oldworld powermacs - they've worked well with Sarge and earlier for a few years now). It's been rock solid, where quik (I think it was quik) was problematic on a 9500 I tried it on, as occasionally it'd lose whatever setting in nvram allowed it to boot into Linux. That may or may not have been a battery problem, but it was a pain.

In any case, I have BootX re-downloaded the current daily build etch netinst cd burnt here.

Is there a preferred version of MacOS to run BootX from to minimise hassles? I have anything from 8.0 to 9.2.2 here.

Thanks for the step-through! I've done this quite a few times before on earlier Debians, but they generally worked so simply I've just left them be, and debugging the process is something I need help with.

Replying to myself not as insanity, but to note to anyone else with the same issues, my beige g3 here is now running etch well. Doing the upgrade from sarge->etch using the most current sarge kernel gives me an etch installation on disk, but a new kernel and initrd that doesn't boot. Downloading a 2.6.17 ppc kernel from ppckernel.org and booting into sarrge from that resulted in an etch installation on disk (as it should have, and as before) but also gives me a kernel with initrd that boots fine, and I've been using for the last couple of days.

I still get the console text corruption, ( same kind as on http:// www.danamania.com/temp/performafail.jpg ) which is a pain - but only a minor one as it doesn't appear to affect stability


Reply to: