[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Network boot of RS/6000 CHRP systems

Sven Luther wrote:
On Tue, Mar 14, 2006 at 06:53:21PM +0100, Alexander Baldeck wrote:
Sven Luther wrote:
On Tue, Mar 14, 2006 at 09:30:29AM -0800, Jason Self wrote:
Perhaps it's the monitor? Have you tried using it with another machine?

On 3/14/06, Maes, Roel <it@edutoy.be> wrote:
Dear sir,

My company just bought a second hand IBM RS/6000 F50 server.
When i try to boot it, onfortunately, the screen remains blank.
I removed the VGA card, en installed an other one, but still, blank screen.
(no input signal detected)
Please connect a serial cable, and try netbooting it through the serial
console (console=ttyS0,9600n8 usually), and post the result of the serial log
if it doesn't work for you.


Sven Luther
If your card is not supported, you may want to try passing:


IBM rs6k chrp boxes boot into vga text mode, so this shoulde be no issue.

Well, I don't know if a PREP/CHRP hybrid exists but mine is a CHRP:

[kth5@yoko ~]$ cat /proc/cpuinfo
processor       : 0
cpu             : 604r
clock           : 374MHz
revision        : 49.2 (pvr 0009 3102)
bogomips        : 372.73
machine         : CHRP IBM,7043-150

And it is indeed a "RS/6000 43p Model 150" as case and Open Firmware splash say. I tried a regular x86 compliant PCI 2.1 gfx card the other day (S3 VirgeGX) and it didn't work. Btw, this machine boots with either yaboot (1.3.14rc1) or using OF bootp, so I guess it is that it is in fact compatible to OF cards to some extend.

in the append line to the kernel. It should then use the already initialized screen from OpenFirmware. If your card has a DVI along with a regular DSUB15 VGA output, make sure that the machine does not detect the wrong output. This happend to me with a ATI Radeon 9200SE PCI MacEdition, my 43p Model 150 randomly chose one on boot time but never probed both properly.

The card in question is probably either a matrox or sis or something such
graphic card, or a special IBM not supported by X nor fbdev one.
Yes, the card that comes with it does not work with Linux as you say.

Another card that works, is a Rage128 PCI usually found in older B&W G3 Powermacs.

In any case, I second Sven's suggestion to use a serial console as it is probably the most reliable solution.



Sven Luther

Reply to: