[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

compile kernel for miboot to boot directly without MacOS

Recently I got an OldWorld Beige G3 (266 Mhz, Gossamer, OpenFirmware 2.0f1,scsi 4Gb disk...). It had MacOS9.2 installed on. With many problems (I was totally newbie on powerpc), I got Debian installed booting the installer with BootX (the Sarge floppy disks didn't work) on a second scsi disk attached to the beast. Nor from the innstaller nor from the Debian system itself, I couldn't install quik on it: "non mac-formatted disk".) I have only succeed to boot by BootX, but: I don't want to boot MacOS only for boot Debian (totally booting time=2x(OS booting time)) Is impossible to boot via OF. I have made ALL trick's that I have founded all over the net: OF doesn't boot even MacOS with the typical scsi/sd@0,0:6,and many others (not even with the whole path (/pci@80000000/.... ). Used "Drive Setup" to patch OF, and so many things that I forgot them :-( .
Well, in short: OF will never run....so  only rest miboot.
After weeks and a lot of hours on google I have founded a miboot*.deb on http://people.debian.org/~luther/, for build my own miboot images. Now I'm making tests with an other disk (an old ide 1,5 Gb) attached like primary master (so /dev/hda), which has been partitioned from MacOS "Drive Setup", in order to allocate the hardisk drivers like recommended on the NetBSD Partition Howto. I installed Debian on /dev/hda6 (this time, due to the MacOS partitioning scheme, it let me to install quik...not usefull with my OpenFirmware plenty of bugs :-(( ). I have made a little hfs partition (agout 35 Mb) to allocate the miboot and kernel stuff too.

I have only had "succes" on "boot" with a kernel from a boot.img floppy from Luther I think it's that image,( http://people.debian.org/~luther/d-i/images/2006-03-01/powerpc/floppy/ ), but now I don't remember sure. I have said "succes" because it only boot the debian-installer, (and after the floppy root.img has been inserted)....but I want to boot my Debian unstable, not the installer :-( .

Sample commands,runned from Debian, which allow me boot the debian installer from /dev/hda7 (the little hfs partition):

#zImage is the kernel extracted from the boot.img floppy mentioned above, /dev/hda7 unmounted
echo kernel /home/francisco/zImage > /etc/miboot.conf
echo device /dev/hda7 >> /etc/miboot.conf
hformat /dev/hda7

Also allowed me to boot the Debian installer the following commands:
#/home/francisco/boot.img is the floppy image mentioned above
dd if=/home/francisco/boot.img of=/dev/hda7 bs=1024 conv=sync ; sync
#the following line is extracted from the bash script /usr/bin/miboot, which is installed with the miboot*.deb
dd if=/usr/share/miboot/hfs-bootblock.b of=$device count=2 conv=notrunc

To boot, I have only to plug the ide hardrive as Primary Master, and after a while, it prompt me for the root.img floppy. Of course, I have tried to pass different kernel arguments like "root=/dev/hda6" on the kernel line of the miboot.conf, but I only got a tipycal "Kernel panic unable to mount root fs...". To boot again MacOS, I have to unplug the ide harddisk and place it other than Primary Master (Secondary Master, Primary Slave or Secondary Slave).

All the other kernels that I have tried with this method, ended with a red X over the penguin. I tried the official Debian vmlinux-2.6.25-1-powerpc-miboot and the vmlinux-2.6.8-powerpc with their initrd ramdisk images,and a custom compiled 2.6.15 kernel Debian's way, basically I have compiled with this *.config, which seemed me it would work ( http://lists.debian.org/debian-powerpc/2005/10/bz200000.bz2 ) with many kernel arguments, but always the penguin with the red X. The official Debian kernels boot without problems from BootX, not the custom compiled, which shows again the tipycal "Kernel panic unable to mount root fs..." I would like to compile a kernel (if it fits on a floppy, much better: it would be nice to make a floppy rescue disk) to place it on the hfs partition with the miboot stuff. Reading the Luther's *.logs I have added the main/debian-installer repositories to install the kernel-image-2.6.15-1powerpc-miboot-di *.deb, in the hope it includes a *.config that would allow me to work with like a basis, due the fact that's the only kernel that "boot" mi G3,....but no *.config is included :-(((((((((((((((((((( Alll the 4 kernels are ELF executables, not *.coff's or anything else...why only the floppy from the kernel boots and not the others? Is the 2.6.15-1powerpc-miboot-di kernel patched in any special way, it has any special feature compiled in? ??????????????????????
Why this lack of documentation?
In this moment I'm defeated: any help or track would be very pleasant. This beast it's been a pain for me!!!!
Thank's a lot for reading this.

Reply to: