[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: powerbook 6,8 progress and Airport issues!

Matthias Jordan wrote:

Hi, folks!

Emmanuel Galatoulas schrieb:

ifup eth2

what i get is

SIOCSIFFLAGS: No such file or directory
bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load

I'm not sure about it but the following might serve as a thought
model: The above error is a result of the latter line: the driver
couldn't load the firmware and thus failed to load which causes the

In case you actually managed to get some *.fw files out of an
AppleAirport2 file or similar (I got some with the wl_apsta.o
driver) you probably copied them into the wrong directory. The "make
installfw" line from the fwcutter Makefile does not work for Debian
and related distros (I tried it with Ubuntu and failed). You have to
copy the files manually to /lib/hotplug/firmware. I had the same
issues until a friend gave me the right tip.

Hope it helps.


Well a round up of the latest achievments on Airport2!!!

thanks to Matthias reply i did a little googling to find out which
firmware file to download. The following link was enlightening


in particular the following lines:

   * #wget
   * #fwcutter AppleAirPort2
   * #make installfw

which I run from within the source directory of bcm43xx-fwcutter.
The only "correction" to Matthias remarks is that the *.fw files
DO ACTUALLY get installed normally although not in /lib/hotplug/firmware
but  in fact under just /lib/firmware
which in second thought is only reasonable for the following reason
I suppose: the latest version of UDEV makes hotplug obsolete, in fact
apt-get RECOMMENDS someone to purge hotplug after installing
more recent versions of udev (i run version 0.076-5) and it seems
that /lib/firmware is the new directory for firmware stuff!

After that, the interface came up quite smoothly and with the correct
configuration Airport is operational!

(only "error" i get in my syslog is this message:

Dec 12 00:34:10 qubit kernel: bcm43xx: FIXME: Possibly broken code in bcm43xx_phy_setupg() at /usr/src/bcm43xx-20051207/bcm43xx_phy.c:333

which may say something to the more knowledgeable!)

So to wrap up, within only a few days I got a perfectly working
powerbook breaking a six months stale
and all that thanks to  the brilliant work of the community
of developers and users  which makes Debian
(and free software in general)  the powerful force that it is!!!
a big thanks again then!!!!

(PS. A remark which has to do with the temperature of the powerbook.
I noticed that the machine was running quite hotter under the most recent
kernels (>= 2.6.14) than with my older debian kernel 2.6.8. Guy Yasko
pointed to that the therm_adt746x module may be a bit problematic, So
I decided to disable it altogether and eventually this resulted into a much
cooler running machine!! I don't know exactly why but this may be a good hint!

Ah, and of course this mail is sent through Airport!!!)

Emmanuel Galatoulas

Reply to: