[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Reset PegasOS Open Firmware configuration to default



On Tue, Nov 15, 2005 at 04:52:20PM +0100, Turbo Fredriksson wrote:
> Quoting Sven Luther <sven.luther@wanadoo.fr>:
> 
> > On Tue, Nov 15, 2005 at 07:35:01AM +0100, Turbo Fredriksson wrote:
> >> I've been trying to get a 2.6 kernel to boot on my PegasOS (the
> >> kernel load hangs after a couple of seconds).
> >
> > I still don't get this, can you write me your exact problems in
> > personal email ?
> 
> I'm currently working on a mail about this (I've been doing that since
> you told me to hookup a serial console a couple of months ago :)
> 
> I'm busy, and getting 2.6 up and running on the PegasOS is quite

low-priority ? I mean, you are losing time and effort to try something which
has not been support by either genesi, debian or upstream since a couple of
years, and you find no time to get the out-of-the-box working 2.6 kernel up
and running on your box ? 

> low-prio. Although it just jumped up to first place. The PegasOS is
> the only machine I have that can display X 'correctly' (i.e. with
> enough speed to be usable :).

> > Can you boot the debian kernel fine ? 
> 
> That IS the debian kernel! That's the weird part! _MY_ kernels get
> some de-compression errors (can't remember which though).

Ah, it works out of the box, for all pegasos boxes i know about.

> >> devalias serial /pci/isa<something>/<something>/serial<something>
> >> setenv input-device serial
> >> setenv output-device serial
> >> 
> >> This is from the top of my head, can't remember EXACTLY what I
> >> typed...
> >
> > Just remove the keyboard and you will get the serial console, don't
> > forget to boot with console=ttyS1,115200n8.
> 
> That was what I tried. That is usual behaviour on SPARC, and the Open
> Firmware is 'almost' the same (just not as good if you ask me). Before
> I even tried redirecting i/o, I tried to just remove the keyboard - nothing...

mmm, what pegasos revision/model do you have, and what is the date of your
firmware ? 

> >> Either I'm using the wrong physical port (there's two - one 9pin
> >> and one 25pin) and/or the wrong speed (tried 9600/8n1, 38400/8n1
> >> and 115200/8n1).
> >
> > 9pin 115200n8.
> 
> Tried that, didn't work. I later found a page that described 'in
> detail' how to do this, and I saw that I was missing the speed (etc)
> option to the 'devalias' command. Also, I used 'setenv', while the
> page I found said to use 'install-console' and then the FORTH stuff.
> 
> http://www.ppczone.org/article.php?article=serialconsole

Strange. 

> >> Any ideas? Is there an image or something I can boot that will
> >> clear/reset the firmware?
> >
> > You can try an OF upgrade.
> 
> That was what I thought as well, but I couldn't find anything
> about that...

Look at the bapln-gmbh web page.

> Do you have one you can send me? 

I could, even beta ones, please mail me privately, but not before next week.

> >> The machine is set to autoboot my 2.4 kernel so I could mount the
> >> disk in another Linux machine and replace the kernel image with
> >> this 'reset image'... ?
> >
> > forget about 2.4 kernels please.
> 
> As soon as I can get 2.6 working, I will :) But every single 2.6
> kernel I've tried have failed to boot for one reason or other...
> 
> >> PS. Trying the old PC tricks I used to do
> >>     when a PC/BIOS fucks up (remove the battery
> >>     for a couple of hours) didn't work...
> >
> > just do a printenv, and you will see the default listed on the right, and you
> > can reset them by hand.
> 
> Hmmm! Thanx. That helped. NOT :)
> 
> I can't see squat, and nothing I type seem to work/get through.
> What's weird though is that I found a reference to 'F1' after
> first keyboard blink. That seemed to stop the boot process...
> 
> I guess I can try 'type in the blind'. I've done quite extensive
> repairs without any display :)

I don't know, i feel you might have buggy or strange hardware.

Friendly,

Sven Luther



Reply to: