[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

X won't start after emerge --world update

i have been successfully running gentoo and Xorg on my 15" aluminum
powerbook for quite some time now. however, after i ran emerge --update
world a few days ago, X refuses to start up. i tried recompiling my kernel
and going over my xorg.conf file, but can't find anything amiss. when i
run startx, the screen goes black like it always does on startup, the
cursor appears, and then it crashes. here's the output after it crashes:

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.14-rc4 ppc [ELF]
Current Operating System: Linux 8008135 2.6.14-rc4 # SMP Sun Nov 13
03:35:07 UTC 2005 ppc

Build Date: 12 November 2005
Before reporting problems, check http://wiki.X.Org to make sure that you
have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting, (++)
from command line, (!!) notice, (II) informational, (WW) warning, (EE)
error, (NI) not impletmented, (??) unknown.
(==)Log file: "/var/log/Xorg.0.log", Time: Sun Nov 13 03:39:56 2005
(==)Using config file: "/etc/X11/xorg.conf"
Using vt 7
Symbol drmGetClient from module /usr/lib/modules/drivers/radeon_drv.o is
Could not init font path element /usr/share/fonts/local/, removing from list!

waiting for X server to shut down

here are the warnings and errors from the log file:

(WW) RADEON(0): Video BIOS not detected in PCI space!
(WW) RADEON(0): Attempting to read Video BIOS from legacy ISA space!
(WW) RADEON(0): Unrecognized BIOS signature, BIOS data will not be used

(WW) RADEON(0): Video BIOS not detected, using default clock settings!
(WW) RADEON(0): Failed to probe xtal value ! Using default 27MHz

(WW) RADEON(0): Failed to detect secondary monitor, MergedFB/Clone mode

(WW) RADEON(0): Direct rendering not yet supported on Radeon 9500 and
newer cards

Symbol drmGetClient from module /usr/lib/modules/drivers/radeon_drv.o is

Could not init font path element /usr/share/fonts/local/, removing from list!

sorry i did not include the entire log file, i currently don't have
network capabilities on that machine so i had to copy by hand. any
assistance is much appreciated. thanks!

Reply to: