[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Java and Azureus



Paul Brossier wrote:
> On Sun, Jun 12, 2005 at 01:34:27PM +0200, Federico 'Pain' Pistono wrote:
> 
>>I've installed the IBM jre as suggested by the ubuntu PPC guide.
> 
> 
> which one? 
> 
> there is at least 2 different jdk/jre from ibm, and the pseries will
> install and run 'java -version' on a g4 but fail doing pretty much
> anything else. similarly, installing a ppc (not pseries) on a g5 will
> fail too.

# apt-get install java-package
$ pager /usr/share/doc/java-package/README.Debian

[...]

 * IBM (http://www.ibm.com/developerworks/java/jdk/linux140/)
   - The J2SE Development Kit (JDK), version 1.3.1 to 1.4.2, tested on
     x86 and powerpc; other available architectures should work as well
   - The same applies for the J2SE Runtime Environment (JRE)
   - Documentation packages are not yet supported
   - Users of PowerPC architecture must be aware that the
     JITC_PROCESSOR_TYPE environment variable must be properly set in
     order for JIT to work as expected.  The most common setting for
     is the one used for Apple and Pegasos hardware, a value of "6".
     Please see the following resource for details:
     http://www-128.ibm.com/developerworks/linux/library/l-pow-apple.html

[...]

-- 
  .''`.
 : :' :rnaud
 `. `'
   `-
Java Trap: http://www.gnu.org/philosophy/java-trap.html



Reply to: