[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Install guide outdated about Old World disk booting ?



On (15/06/05 05:58), Thomas Carlson wrote:
> I have been waiting to see some response to this post.  Are there  
> others out there who have had success with Sarge on Old World machines.  
>  My Powermac 9500 is partitioned and ready to go once the CD set  
> arrives in the mail.  I plan to use BootX so I can continue to  
> dual-boot OS X.  Any advice is welcome.
> 
> Tom
> 
> On Tuesday, June 14, 2005, at 12:45 PM, Noé Falzon wrote:
> 
> >I recently tried to install Sarge on my Performa 6400, and I followed  
> >the instructions given in the latest install guide. But on section  
> >4.5.1, here :
> >http://www.debian.org/releases/stable/powerpc/ch04s05.html.en
> >they ask to use a Kernel and RamDisk from the Woody release. And  
> >indeed, when the install is complete, Debian 3.0 is installed, andthe  
> >Kernel is 2.2.
> >
> >So I tried to get the files myself from the Sarge distfiles located  
> >here :
> >debian/dists/sarge/main/installer-powerpc/current/images/powerpc/ 
> >netboot/
> >I used the vmlinux kernel, and initrd.gz ramdisk. Everything went  
> >right during the install.
> >But when I rebooted into the newly installed system, a kernel panic  
> >occured saying that it couldn't load the root partition. I double  
> >checked the names of partitions and the partionning stage, and it  
> >should be ok.
> >
> >Does anyone know if the guide will be updated, and/or how to solve my  
> >boot problem ?

I used the sarge installer (netinst.iso) to install on a couple of beige
G3's (Old World) before release.  Everything worked fine although I
recall having to fiddle around to get the kernel files from the installed 
system copied to the macOS partition.

This is what you need to do to use BootX.  First you copy the vmlinux
kernel and initrd.gz ramdisk from the Install CD into your Mac System
Folder, boot the installer from BootX and complete the install up to the
point of having to reboot but DON'T.  hit F2 or F3 for a shell and then
copy the vmlinux kernel and initrd.gz files to the MAC partition.

This is where my memory is somewhat hazy (I no longer have the boxes
available).  If you check back through the archives you should find some
references.  During the install make sure you install the mac hfs file
modules.

Sorry I can't be more help but someone else may be ;)

Regards

Clive


-- 
www.clivemenzies.co.uk ...
...strategies for business




Reply to: