[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: install 2nd HD G5

Wesley Smith wrote:

Please excuse the many messages...I tried the following at the
openfirmware prompt:

boot /ht@0,f2000000/pci@5/k2-sata-root@c/k2-sata@1/disk@0:2,\yaboot

and got the error

MAC-PARTS: specified partition is not valid
BOOTP/BSPD failed, no FILENAME specified|id

any thoughts?


I use "boot sdb1:,\\yaboot" in OF to boot using my second SATA disk.

This brings up the boot prompt from where I choose my kernel.



On 6/4/05, Wesley Smith <wesley.hoke@gmail.com> wrote:
ps...here/s the output of ybin -debug where root is my sdb3 mount point:

ybin: DEBUG: macosx set to
`/ht@0,f2000000/pci@7/k2-sata-root@c/k2-sata@0/disk@0 :9' from
ybin: DEBUG: OS=4
ybin: DEBUG: /bin/sh /usr/lib/yaboot/ofboot 4 bootyaboot 10  0 yaboot
GNU l /ht@ 0.f2000000/pci@5/k2-sata-root@c/k2-sata@1/disk@0:2
,\\yaboot   macosx MacOSX x /
ht@0,f2000000/pci@7/k2-sata-root@c/k2-sata@0/disk@0:9 ,\\:tbxi  cd
CDROM c cd: , \\:tbxi  of OpenFirmware o quit now
ybin: DEBUG: set magicboot to /tmp/ofboot.ytmPmc
ybin: DEBUG: boot-device=/ht@0.f2000000/pci@5/k2-sata-root@c/k2-sata@1/disk@0:2,

On 6/5/05, Wesley Smith <wesley.hoke@gmail.com> wrote:
Hi guys, thanks for the info.  Here's what I've done:

--mount sdb3
--edit yaboot.conf
--chroot /mnt/sdb3 (where sdb3 is mounted)
--mount -t proc none /proc
--ybin -v

I also tried

--mount sdb3
--edit yaboot.conf
--chroot /mnt/sdb3 (where sdb3 is mounted)
--mount -t proc none /proc
--mount /mnt/sdb3 /usr/sbin/ybin

neither of these have solved by booting problem.  I am completely
stumped here.  Are there config files somewhere that ybin create that
I can look for on sdb3 or sdb2 to see if my yaboot.conf changes are
reflected in the ybin -v output?


On 6/4/05, Jeff Green <greenjb@unk.edu> wrote:
Wesley writes:
You're right that I don't need to do the source thing.  I do have a
question about "chroot /mnt/ur.sdb3.mnt.pt /usr/sbin/ybin" however.
By doing this command, will ybin now access the modified yaboot.conf
in sdb3?  What is it that chroot is doing in this command?  I realize
this is a basic question, but I'm kind of fuzzy on what the function
of chroot is.


Things get complicated, and "chroot" is a way of simplifying the
situation. Most commands do not run in isolation, i.e. they're not
statically compiled nor run independent of support files. As a
consequence "chroot" allows you to run "that" command in the environment
that it was intended to run. So by doing a chroot on the ybin, you not
only selected the proper yaboot.conf, but also you used a different
ybin, i.e. the one on your installed system and not the one on the
ubuntu livecd. It then used the OF support files on *your* installed
system and everything else that your yaboot.conf is implicitly relying
upon. It's really pretty nifty.



Reply to: