[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: munged yaboot.conf

On Tue, May 31, 2005 at 09:00:56PM -0700, james houston wrote:
> I have OS X (10.4.1) and Sarge on my iBook (dual USB).
> I tried to customize my yaboot.conf file and messed up
> the syntax so now when I choose "l" in yaboot, I get
> this error:
> Config file error: newline is not allowed in quoted
> strings near line 7 in file \\yaboot.conf
> Syntax error or read error config
> How can I edit the yaboot.conf file safely? I read in
> the archives about editing it from OS X, but that was
> discouraged. What is the best direction to go then?

Since you get the yaboot prompt, you could directly type the 
path to your kernel, like:


if your root is on partition 3. The first partition is number 1
in yaboot.

> I tried booting from my Sarge installation CD and
> choosing "Execute a shell" but my hard drive was not
> mounted on "/target" as it said it would be.

The hard driver partition gets mounted at a later time in the
install process. You could step through more steps of the install
process if you don't know where your root partition is, or mount
it manually from your shell using:

mount /dev/hda3 /target

if your root is on partition 3. After editing yaboot.conf run ybin
ybin -C /target/etc/yaboot.conf
because of the non-standard path.

I hope you actually don't need this tip anymore, but: always keep
at least one safe backup choice in your yaboot.conf. Something like:

30 years from now GNU/Linux will be as redundant a term as UNIX/MERT is 
today. - Martin Habets

Reply to: