[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Compile Errors on 2.6.8 for Johannes' Trackpad Driver


> Read about your trackpad driver on debian-powerpc here:
> http://lists.debian.org/debian-powerpc/2005/03/msg00984.html


> I'm using a 2.6.8 kernel (the default one from debian 
> Sarge net install 2.6.8-12) and the trackpad driver didn't 
> compile so well. I suppose I'll try a 2.6.11 kernel next, 
> but here's what happened if it helps you:

> error: too many arguments to function `kref_put'
> error: too few arguments to function `kref_init'
> error: too many arguments to function `kref_put'

Thanks for letting me know. I suppose the kref API has changed.

Now, I don't think I'll be fixing this. With that old kernel
 * you won't have sound
 * your powerbook isn't running at full possible speed
 * there'll be a couple of other quirks...

Take a look at http://johannes.sipsolutions.net/PowerBook for the
patches I currently use with my kernel... I suppose a bunch of them
won't work properly for 2.6.8 (and you have no reason to use 2.6.8 if
you need to compile anyway, and you do for those patches)...

If you really want this for 2.6.8 I can take a look at it, but I don't
think it makes much sense. What do you think?


Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: