[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: unable to mount hfs+ partition read/write

On Sat, 02 Apr 2005 the mental interface of
Andre Lehovich told:

> I'm getting the following error message when I try to mount
> my OS-X partition read/write (Debian's 2.6.8-9 kernel):
> # mount -t hfsplus -o rw /dev/hda5 /osx
> # dmesg | tail -1
> HFS+-fs warning: Filesystem was not cleanly unmounted, running fsck.hfsplus is recommended.  mounting read-only.
> There doesn't seem to be an fsck.hfsplus.  Based on advice
> found in the list archives, I tried booting OS-X in
> single-user mode (hold down command-S while booting),
> running "/sbin/fsck -f", and then rebooting into Debian, but
> that did not fix the problem.
> Another trick which worked for some people is using
> "hpmount /dev/hda5", but that gives me the error:
> hpmount: /dev/hda5: Neither Wrapper nor native HFS+ volume header found (Unknown error 4294967295)
> How do I convince Linux that this filesystem is clean?  The
> OS-X fsck finds no problems with it.

# apt-get install hfplus
# hpumount
# mount -t hfsplus /dev/hda5 /osx


  You cannot propel yourself forward by
  patting yourself on the back.

Reply to: