[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [maybe SOLVED?]: fstab, hotplug, udev, usb/ide/scsi volumes

Jan C. Nordholz wrote:
On Sat, Apr 02, 2005 at 12:09:26AM -0500, Matt Price wrote:

Hey everyone,

OK, I think I'm making some progress.  I reckon there were two kinds
of problems in my case:

1) usb not working: the newer 2.6 kernels seem to need to have the usb
modules (hid, uhci, ehci, etc) explicitly declared ("statically
linked"?) in /etc/modules.

2) hotplug/udev not working:  when udev and hotplug packages are
installed, devices of the type /dev/[h|s]d[a|b|c...][1-9] are not
automatically generated; when the kernel tries to mount my non-root
partitions after udev has been activated, it fails and dumps me into
single-user mode.  From there I can /etc/init.d/udev stop, and
continue with the boot...

I didn't know you were using udev (the web-posted config doesn't show
that) - I've had much trouble with devfs and udev myself, so my first
advice would've been to switch back to a "static" /dev. ;-)
Sadly I don't know enough about udev's internals to diagnose your or
my problem there...

thanks Jan for all my help, but everything seems to be working now -- and udev actually is a major help for me, since it means that my firwire disk, usb pen drive, and digital camera can now be plugged in in any order I want without messing up my fstab entries...

but I think my problem actually had very little to do with the kernel,and maybe I didn't even have to list all those modules in /etc/modules. Instead, I had to modify two linesi n my /etc/fstab:

I had previously:
none /sys sysfs noauto 0 0
usbdevfs /proc/bus/usb usbdevfs defaults 0 0

under 2.4 kernels without devfs I guess the first one didn't matter and the second one worked fine. in newer 2.6 kernels using hotplug the "noauto" option in /sys was fatal and the usbdevfs no longer worked, so I had to change these to:

none /proc/bus/usb usbfs defaults 0 0
none /sys sysfs defaults 0 0

suddenly everything works! Now I just need to figure out a way to use udev to trigger complex events like, e.g., seeing my camera, notifying me in x that it's been mounted, transfering all the pictures, and opening up a photo browser... but hopefully osmeone's already done that for me?

thanks again jan,


ps now that udev actually works I highly recommend it. the rules system makes sense once you start playing around with it.

 .''`.       Matt Price
: :'  :      Debian User
`. `'` 	     & hemi-geek
don't use these addresses:  aardvark@derailleur.org, zeus@derailleur.org

Reply to: