[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: "Virtual Terminal"

Jochen Voss wrote:

Hello Michael,

On Mon, Mar 21, 2005 at 09:11:29PM -0800, Michael wrote:
I did change my /var/apt/sources.list file, or /etc, I forget whether it was in /etc or /var, ...

It is in /etc.  All the configuration files you ever want to edit
should be in /etc.

.., and being the fan of wiping and reinstalling as often as I do, ...

You might want to get used to Debians update mechanism instead of
reinstalling often.  One of the good things about Debian is, that
updating really works well.

Now to get into the actual post, sorry for rambling on, do you need to have an X server running in order to use "virtual terminal" as I asked about the keys for in a recent post, or should I be able to do it without?

I think you mean "virtual consoles", do you?  No X server is needed,
this feature is built into the Linux kernel.  The presence of an X
server might make a difference though: the keys to switch between the
different consoles might be slightly different.  Try Control-Alt-F2
(all pressed together) or Control-Apple-F2 or Alt-F2 or Apple-F2.  If
you get an empty text-mode console showing the login prompt it worked.
Switching back to the X-server, if any, works then with
Control-Apple-F7 or Control-Apple-F7.

All the best,
I am pretty sure that I tried all those keys, and yes I did mean "virtual consoles". Could I have a wrong keymap selected? If it helps I am using a macally iMedia key. Except for macally's extra keys at the top it looks like a regular extended keyboard. One quirk I have noticed is that in order to use my number pad, I have to push the "num lock/clear" button. That's normal I guess. But when I do push it the scroll lock, caps lock, and num lock light, light up. But typing still works in lower case. However when I push caps lock the num lock light goes off but the other two stay on. But the caps lock otherwise works like it should. Also after I put the num lock on the arrow keys no longer work. Is this normal, or do I have the wrong keymap selected. I am reluctant to change the keymap though, because every time I have, I have had to reinstall because my keyboard no longer worked, and I have been unable to find the site that had instructions for using the boot cd to change the keymap.

As a note I apologize for rthis, my mailer just bounced it back to me, I had the address wrong

Reply to: