[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: pre-release 2.6.11-0.1 debian/powerpc kernel.

Hello Sven,

On Tue, Mar 08, 2005 at 07:49:38PM +0100, Sven Luther wrote:
> I am in the process of uploading a pre-release 2.6.11 debian/powerpc
> kernel to
>   http://people.debian.org/~luther/powerpc/2.6.11-0.1 
> And altough it is not yet fully ready to be uploaded (mostly because
> kernel-source-2.6.11 needs cleaning up a bit yet), i would encourage you to
> try it out and give me feedback on it.

I gave it a try on my very recent Apple powerbook G4.  Information
about my machine, dmesg output etc.  can be found at
http://seehuhn.de/comp/powerbook/2.6.11-0.1/ .  The following things
did not work:

1) the trackpad does not work :-(

  Using the trackpad has no visible effect, no input arrives at
  /dev/input/mice, the X pointer does not move etc.

2) sound does not work

  Everything seems fine at first: alsamixer sees controls labelled
  "master", "headphon", "Mix Boos", "PC Speak", "Auto Mut", "Beep".
  Doing "cat something.wav >/dev/audio" or similar takes the
  appropriate amount of time.  But no sound is actually played :-(

3) the "fn" key emits no scan code

  I tried "showkey -s" on the console.  Pressing "fn" does not result
  in any output.

4) suspend does not work

  I tried the following shell script:
	rmmod ohci1394
	rmmod eth1394
	rmmod ieee1394
	rmmod hci_usb
	/etc/init.d/hotplug stop
	echo disk > /sys/power/state
  When the final line was executed the machine hung.  The cursor on
  the text console was still blinking, but all key presses were
  ignored and I had to do a hard reset.

The dmesg output contains the following lines which look like error

  - no idea about this:

	Can't get bus-range for /pci@f2000000/cardbus@13, assuming it starts at 0
	PCI: Cannot allocate resource region 0 of device 0001:10:19.0

  - graphics seem to work, so maybe the following is harmless?

	radeonfb (0000:00:10.0): Invalid ROM signature 303 should be0xaa55

  - the following is known, I think:

	adt746x: Thermostat bus: 0, address: 0x2e, limit_adjust: 0, fan_speed: -1
	adt746x: Thermostat failed to read config from bus 0 !

  - no idea about this:

	ohci1394: fw-host0: Unexpected PCI resource length of 1000!

  - maybe the following is connected to the trackpad problem

	input: USB HID v1.10 Keyboard [Apple Computer Apple Internal Keyboard/Trackpad] on usb-0001:10:1a.0-2
	HID device not claimed by input or hiddev
	usbhid: probe of 1-2:1.1 failed with error -5

As far as I can see, all of these problems also occur for a vanilla
2.6.11 kernel.

I hope this helps,

Attachment: signature.asc
Description: Digital signature

Reply to: