[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: OT: Re: Netatalk over a wireless router?

Yes. It doesn't say much other than the fact that the router is supposed
to work with MAC OS, Windows and Linux. "Work" seems to be a pretty
general term in this context.


well tcpip works so....

it does, use cups and can connect to printers in a million different ways. including (from the add printers dialog) appletalk, bluetooth, ipprinting, open directory??, rendezvous (which is just some rename of dns discovery stuff), usb and windows printing.

It seems strange that it uses cups but doesn't have any provision for
printing to a Linux machine running cups. Using the LPD/LPR/IP printing
option requires enabling the LPR compatability server in Cups. Probably
not a problem, but why add an extra layer if you don't have to?

I also don't see any mention of Windows/SMB printing on mine. This iBook
is running 10.2.8. What version are you running?

10.3.6, i have normal macosx and macosx server

its worth mentioning that windows networking changes dramamtically
from like 10.3.2 to 10.3.3 - somewhere in there anyway. if you so
an install from the panter discs and then auto update youll find
that windows networking works differently.

also after you auto update, samba versions will sometimes up
as well - no suprises there.

i havent played with cups to cups printing. ive only used
windows shared printers and intelligent printers (various brands)

mine also seems to have special mentions of 'epson appletalk/firewire/tcpip/usb' hp ip printing, and lexmark inkjet networking. printing over firewire.... hmm
interesting. under ip printing are options for randezvous (if you
missed it the first time), LPD/LPR, internet printing protocol,
socket/hp jet direct.

anyway so it doesnt seem that finding an alternative print solution
should be a huge drama. i would just go with lpr/lpd. as mentioned
macosx uses cups for its printing , with gimp-print.

After enabling the lpr compatability server in Cups, IP printing does
indeed work. Except that it's currently spewing raw postscript out the
printer, so I guess I have some more tweaking to do.

hopefully you have a postscript printer, else its time for
some printer drivers.

to add some interesting thoughts to the pile, i thought that appletalk
was running inside of tcpip when using netatalk and thus would be
a non-issue for tcpip only network hardware. thats just my impression.
i dont use appletalk. windows file sharing works for me ;)

My understanding was that it can but doesn't have to. It's Appletalk
over Ethernet, but not necessarily inside tcpip. Hence the reason
netatalk's /etc/netatalk/afpd.conf has -ddp and -tcp options.
My guess would be that by using an ip instead of a netatalk machine
name, you're forcing OS X to use netatalk over tcp/ip.

most likely. i would be inclined to agree.

It does seem most problems can be worked around now with OS X. Which is
better than previous Mac OS versions, but still not quite as smooth as I
would have liked. I guess maybe I'm getting too spoiled by Linux. :-)
macosx is pretty good though. i quite like it.
your older version might be tainting your experience :P


WWW: http://dean.bong.com.au  LAN: http://www.bong.com.au
EMAIL: dean@bong.com.au       or       djzort@bong.com.au
ICQ: 16867613

Reply to: