[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PowerBook G4 config for

Colin Leroy wrote:

I cannot compile a vanilla 2.6.10-rc2 kernel using make-kpkg clean && make-kpkg kernel-image in an up to date Debian Sid. I get this error:


from bk are needed.

Ok, I tried 2.6.10-rc2-bk3 (yes, it's not exactly what you told me, but I thought it would work -sorry!) and I get a new (different) error:

  CC      drivers/ieee1394/dma.o
In file included from include/asm/pci.h:12,
                 from include/linux/pci.h:877,
                 from drivers/ieee1394/dma.h:13,
                 from drivers/ieee1394/dma.c:14:
include/asm-generic/pci-dma-compat.h:12: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
For Debian GNU/Linux specific bug reporting instructions, see
make[3]: *** [drivers/ieee1394/dma.o] Error 1
make[2]: *** [drivers/ieee1394] Error 2
make[1]: *** [drivers] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.10-rc2-bk3'
make: *** [stamp-build] Error 2

P.S. Ok, ok, I am going to try just the three patches you gave me! :-)

Jaume Sabater

"Ubi sapientas ibi libertas"

Reply to: