[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: No HFS driver, and "change install priority" menu option missing -- and other bugs found while testing 2.4 boot floppies on OldWorld PowerMac

On Fri, 1 Oct 2004, Sven Luther wrote:
> Geert, you can probably help us here, the current scenario is :
>   - 2.4 floppies, either work fine, the frambuffer takes over and we see the
>     kernel boot info, or fail because of miboot problems, and we see a red
>     cross over the miboot stuff.

Who draws the red cross?

>   - 2.6 floppies, they load and then just before the framebuffer takes over,
>     we see a the small miboot icon changing color (like inverted video). When
>     it worked it would stay like that for a second or two, and then the
>     frambuffer device takes over and we see the log message. When it doesn't
>     work, we don't see the red cross, but we see the inverted video mode
>     (which meens the kernel booted, and the fbdev device is trying to take
>     over the video output), but then nothing, which i believe means the kernel
>     died in this step.
> This is using the valkyrie fbdev driver. What is strange is that the same
> kernel when booted with bootx (or miboot) has absolutely no problem.

Erhm, what makes you think I know what's the problem? I have almost no
experience with `real' Macs.

> I won't have time in the next 2 weeks, but it would be interesting to get the
> early console info on the serial log. One thing is that at first it didn't
> work, and that it started working when i tried to redirect /dev/ttyS1 to the
> serial console, and added that option to miboot.

Serial console is definitely the way to go! You may want to hack
kernel/printk.c:printk() to call the serial output routine directly.



Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds

Reply to: