[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: install (boot) problem sarge powerbook G3 (wallstreet)

dylan wrote:

> on 04.9.11 10:17 AM, Sebastiaan Molenaar at debian@macktic.co.uk was
> reported to have writen:
>> Hi all,
>> This is starting to drive me crazy by now so I hope someone has got an
>> answer.
>> I'm trying to install Debian on my Powerbook G3 (wallstreet)
>> Base install seems to work allright, but I can't get the system booted.
>> quik doesn't seem to work, and when I try bootx I get the following
>> message:
>> VFS: Cannot open root device "hda7" or unknown-block(0,0)
>> Please append a correct "root=" boot option
>> Kernel panic: VFS: Unable to mount root fs on unknown-block(0,0)
>> I'm using BootX v1.2.2 (hoping to use quik later on so I can do away
>> with my mac partition)
>> If I drop to shell during install I see that hda7 is mounted as:
>> /dev/ide/host0/bus0/target0/lun0/part7
>> When I try to put that in the box in BootX I get the same error message
>> (obviously with "hda7" replaced with "/dev/ide......")
>> Any help would be greatly appriciated.
>> Greetz,
>> Seb.
> FWIT, I am having the exact same problem. I can boot into the new system
> with the 2.4 series kernel without any problems using BootX... however
> attempting to boot with a 2.6 series kernel results in the same error that
> Sebastian is having...
> ....?
> Dylan
Hi !

I dont use BootX. But make sure you have copied the initrd and the vmlinux
to the macos folders and slected the initrd as ramdisk?

Bye Chris.

Reply to: