[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: hfs+ fs with linux - only ro after some time error

[...] Oh, and after 32
rw mounts, you need to use the hfpmount on it, which will fail but will
allow the kernel to mount it.

I use 2.6.7.

I had a similar problem: with the early 2.6 testing
kernels I could write on the hfs+ volume just fine (also with 2.4 benh kernels after the new ardistech hfsplus code was merged iirc), yet suddenly it threw an error when I tried to mount it rw[1].

Running OS X fsck.hfsplus on it didnt change it yet your suggestion with hpmount/hpumount (in the debian package hfsplus ftr) fixed it. That was rather unexpected and I didn't make a copy of the first few sectors where the relevant bit was flipped so maybe mount or the kernel misses something upon unmounting an hfsplus volume?


# mount -t hfsplus /dev/hda2 /osx -o rw
# mount | grep osx
/dev/hda2 on /osx type hfsplus (rw)
# dmesg | tail -1
HFS+-fs warning: Filesystem was not cleanly unmounted, running
fsck.hfsplus is recommended.  mounting read-only.
# touch /osx/test
touch: cannot touch `/osx/test': Read-only file system

Reply to: