[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: newbie XF86Config G4 867

hello jon...

i do not have your machine, but perhaps i can be of some help, anyway...

* jon salenger <salenger@sbcglobal.net> [2004-07-28 09:23 +0200]:

> I've been working on configuring XFree86 for a couple of days, now. I keep
> getting "fatal error: no screens found." I'm still a bit unsure, as there's
> more than one config tool (eg, dpkg-reconfigure xserver-xfree86,
> xf86config), and more than one config file - /etc/X11/XF86Config-4,
> /root/XF86Config.new (at this point I'm assuming that the important file (on
> my system) is /etc/X11/XF86Config-4 based on reading the
> /var/log/XFree86.0.log and man XF86Config-4. Is the /root file intended to
> replace the /etc/X11 file, or is it for the root user's use or something
> else? (I tried replacing, just for the heck of it, and a bunch of other
> stuff, but so far, nothing has worked.)
> If I can't get a solution, I'll keep mucking around, trying to figure out
> where, for instance, dpkg-reconfigure writes the file (xf66config is much
> more explicit about this) and messing around with some of the settings,
> trying different config files/locations (according to "man XF86Config-4"),
> etc..

if the suggestions below, do not help, i recommend moving all these config
files away and then issue "dpkg-reconfigure xserver-xfree86". in my
experience, only /etc/X11/XF86Config-4 should be the config to use.

> [SIDE NOTE: I'm learning, as it was sorely required, to send mail from bash.
> I got it to send mail to my GF, but not to my email (sbcglobal.net) address.
> I've experimented enough (same cmd, differrent address) to suspect there's
> some block on my email (though nothing I did). I had to send these files to
> her and then forward them back to me, go into OSX and retrieve them to
> assemble this mail. Anyone have any idea why I can't send myself mail?
> Anyone know of a good howto on mail? I've read a few that weren't too
> helpful (e.g. AT&T network manual), and the man pages (while useful) are
> still a bit cryptic and sparse for me.]

perhaps the Linux Mail User HOWTO helps you, get the package
"doc-linux-text" and
$ zless /usr/share/doc/HOWTO/en-text/Mail-User-HOWTO.gz

> At this point, I'm guessing that the BusID for the video card is wrong, but
> neither Apple System Profiler nor lspci made it very clear what the ID is in
> 0:0:0 format. Googling didn't help much either.

i am not so sure either, but my lspci says:

0000:00:10.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]

while my /etc/X11/XF86Config-4 says:

Section "Device"
    Identifier  "ATI Mobility Radeon 9600"
    Driver      "radeon"
    BusID       "PCI:0:16:0"
    Option      "UseFBDev" "true"
    Option      "AGPMode" "4"
    Option      "EnablePageFlip"
    Option      "DRIReinit"

so it seems that lspci is hex and XF86Config-4 is dec. send us your
output of "lspci".

> (II) Primary Device is: PCI 00:10:0
> (WW) NV: No matching Device section for instance (BusID PCI:0:16:0) found
> (EE) No devices detected.
> Fatal server error:
> no screens found

you might also try with leaving out BusID completely, sometimes it
works (on x86).

::: .O.
::: ..O
::: OOO
::: lynx -source http://www.kodeaffe.de/shensche.pub | gpg --import

Attachment: signature.asc
Description: Digital signature

Reply to: