[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installation package - PowerPC sarge d-i tcl1 and upgrade to 2.6.7 smp kernel

On (15/07/04 15:32), Sven Luther wrote:
> On Thu, Jul 15, 2004 at 01:27:19PM +0100, Clive Menzies wrote:
> > 	It all worked pretty much "out of the box" - thanks for a very
> > 	smooth installer ;)
> > 
> > 	Installing 2.6.7-powerpc-smp worked seamlessly on the new
> > 	install and sound, network etc. worked straight away.  However,
> > 	I haven't yet installed all the software that I use on my
> > 	production box although I did upgrade to sid.  The initrd.img is
> > 	in /boot on this installation and I amended yaboot accordingly.
> > 
> > 	Installing 2.6.7-powerpc-smp on my production system, replacing
> > 	a custom 2.4.23-ben1.031224 which I'd compiled with HighMem,
> > 	smp, dma sound etc. produced some interesting results - none
> > 	insurmountable:
> > 	The initrd.img is in / on this installation but I amended yaboot
> Strange. How did that happen ? And was the initrd really in /, or just
> its symlink ? 
Maybe, I need to be more explict ;)  

On the new install the symlink "initrd.img" is in /boot but on my
production system it is in /.  On both sytems, the actual
initrd.img-2.6.7-powerpc-smp is in /boot.  So it is the symlink
references in yaboot that need to be different.  Not a serious problem
but during the installation, some comment on identifying where the
symlink resides might be helpful.

> > 	assuming that it was in /boot and managed get my production
> > 	system into an unbootable state. However, mounting the partition
> > 	in the new install allowed me to find initrd.img, update yaboot,
> > 	and get my system back ;)  I'm in danger of becoming a geek -
> > 	eek ;)
> > 
> > 	I lost network connectivity because eth0 was taken over by
> > 	ip1394 but amending /etc/network/interfaces cured the problem.
> > 	From dmesg:
> Yes, this is the module loader problem, where discover, hotplug and
> /etc/modules and the modules loaded by the initrd conflict. only hotplug
> usually loads the firewire before the network, and it is usually called
> after discover. Do you have discover installed ? If yes, which version ?
> And does it work ?
Ah! I don't have discover on my production system which is probably why
they loaded out of sequence.  I don't use firewire, so presumably I
could remove this module?

> > 	ip1394: eth0: IEEE-1394 IPv4 over 1394 Ethernet (fw-host0)
> > 	eth1: Sun GEM (PCI) 10/100/1000BaseT Ethernet 00:30:65:7b:b0:7a
> > 	Interesting that on the new install, the SunGem is eth0
> > 
> > 	On the production system on starting kde I've now got:
> > 	"Sound server informational message:
> > 	Error while initializing the sound driver:
> > 	SNDCTL_DSP_SETFMT failed - Invalid argument
> > 	The sound server will continue, using the null output device."
> > 	However, xmms seems to play CD's fine (using the OSS Driver and
> > 	cdread)
> > 	Again the new install doesn't produce the same error.
> some alsa interaction, i guess.
I've been meaning to explore alsa as an alternative to OSS - added to my
list of "stuff to do" ;)
> > 	I also get a fatal error message on bootup saying something like
> > 	"no printer module available" but as printing is via the network
> > 	(using cups), it is not a problem. Again not on new install.
> Any idea on who generates this ?
It comes up during boot but doesn't seem to appear in dmesg.  I'll
investigate further.  But is possibly down to the absence of discover on
the production system?

> > 	It may be too early to judge but the new kernel is working fine
> > 	and will enable me to add functionally that I haven't as yet
> > 	attained with 2.4.23
> > 
> > 	It is also very satisfactory to be able to use a stock kernel
> > 	rather than having to compile ;)
> Thanks, and thanks for your report.
> > 	So thanks a bunch to all you developers and maintainers for your
> > 	excellent work!
> No problem,


strategies for business

Reply to: