[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

PowerPC sarge d-i tcl1 and upgrade to 2.6.7 smp kernel


'xcuse the cross post but given some recent comments on the 2.6.7
kernel on powerpc, I thought this may be useful.

Debian-installer-version: sarge powerpc tcl.1 9 June 2004
uname -a: Linux Apollo 2.6.7-powerpc-smp #1 SMP Sat Jul 10 04:14:32 CEST
2004 ppc GNU/Linux after installing new kernel replacing 2.4.25 or
2.4.26 - can't remember ;)
Date: 15 July 2004 circa 1pm BST

Method: Booted and installed off CD image  Proxied=No

Machine: PowerMac G4 Gigabit Ethernet
Processor: 450MHz Dual Processor
Memory: 896Mb
Root Device: IDE: ATA Disk Maxtor 53073U6

Root Size/partition table: 
        #                    type name                 length   base
	#                    ( size )  system
	/dev/hda1     Apple_partition_map Apple                    63 @
	1        ( 31.5k)  Partition map
	/dev/hda2         Apple_Bootstrap bootstrap              1600 @
	20011166 (800.0k)  NewWorld bootblock
	/dev/hda3          Apple_Driver43 Macintosh                54 @
	64       ( 27.0k)  Driver 4.3
	/dev/hda4          Apple_Driver43 Macintosh                74 @
	118      ( 37.0k)  Driver 4.3
	/dev/hda5        Apple_Driver_ATA Macintosh                54 @
	192      ( 27.0k)  Unknown
	/dev/hda6        Apple_Driver_ATA Macintosh                74 @
	246      ( 37.0k)  Unknown
	/dev/hda7          Apple_FWDriver Macintosh               200 @
	320      (100.0k)  Unknown
	/dev/hda8      Apple_Driver_IOKit Macintosh               512 @
	520      (256.0k)  Unknown
	/dev/hda9           Apple_Patches Patch Partition         512 @
	1032     (256.0k)  Unknown
	/dev/hda10              Apple_HFS untitled           20009622 @
	1544     (  9.5G)  HFS
	/dev/hda11        Apple_UNIX_SVR2 swap                2097152 @
	20012766 (  1.0G)  Linux swap
	/dev/hda12        Apple_UNIX_SVR2 /usr               10485760 @
	22109918 (  5.0G)  Linux native
	/dev/hda13        Apple_UNIX_SVR2 /var                2097152 @
	32595678 (  1.0G)  Linux native
	/dev/hda14        Apple_UNIX_SVR2 /tmp               10690560 @
	34692830 (  5.1G)  Linux native
	/dev/hda15        Apple_UNIX_SVR2 /home               7168000 @
	45383390 (  3.4G)  Linux native
	/dev/hda16        Apple_UNIX_SVR2 /(production system)1024000 @
	52551390 (500.0M)  Linux native
	/dev/hda17        Apple_UNIX_SVR2 /(new install)      5468751 @
	53575390 (  2.6G)  Linux native
	/dev/hda18        Apple_UNIX_SVR2 /var(new install)   986291 @
	59044141 (481.6M)  Linux native

	Block size=512, Number of Blocks=60030432
	DeviceType=0x0, DeviceId=0x0
	1: @ 64 for 23, type=0x1
	2: @ 118 for 36, type=0xffff
	3: @ 192 for 21, type=0x701
	4: @ 246 for 34, type=0xf8ff

	Production system is sid upgraded from woody install Dec 2003 -
	kernel upgraded 14 July 2004 from benh to 2.6.7-powerpc-smp #1
	SMP Sat Jul 10 04:14:32 CEST 2004 ppc GNU/Linux

	Output of lspci:

	0000:00:0b.0 Host bridge: Apple Computer Inc. UniNorth AGP
	0000:00:10.0 VGA compatible controller: ATI Technologies Inc
	Rage 128 PF/PRO AGP 4x TMDS
	0001:01:0b.0 Host bridge: Apple Computer Inc. UniNorth PCI
	0001:01:0d.0 PCI bridge: Digital Equipment Corporation DECchip
	21154 (rev 05)
	0001:02:07.0 ff00: Apple Computer Inc. KeyLargo Mac I/O (rev 03)
	0001:02:08.0 USB Controller: Apple Computer Inc. KeyLargo USB
	0001:02:09.0 USB Controller: Apple Computer Inc. KeyLargo USB
	0001:02:0a.0 FireWire (IEEE 1394): Texas Instruments TSB12LV26
	IEEE-1394 Controller (Link)
	0002:03:0b.0 Host bridge: Apple Computer Inc. UniNorth Internal
	0002:03:0f.0 Ethernet controller: Apple Computer Inc. UniNorth
	GMAC (Sun GEM) (rev 01)

	Base System Installation Checklist:

	Initial boot worked:    [O]
	Configure network HW:   [O] 
	Config network:         [O] wish list - option to configure manually
	Detect CD:              [O]
	Load installer modules: [O]
	Detect hard drives:     [O]
	Partition hard drives:  [O]
	Create file systems:    [O]
	Mount partitions:       [O]
	Install base system:    [O]
	Install boot loader:    [O]
	Reboot:                 [O]
	[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try


	It all worked pretty much "out of the box" - thanks for a very
	smooth installer ;)

	Installing 2.6.7-powerpc-smp worked seamlessly on the new
	install and sound, network etc. worked straight away.  However,
	I haven't yet installed all the software that I use on my
	production box although I did upgrade to sid.  The initrd.img is
	in /boot on this installation and I amended yaboot accordingly.

	Installing 2.6.7-powerpc-smp on my production system, replacing
	a custom 2.4.23-ben1.031224 which I'd compiled with HighMem,
	smp, dma sound etc. produced some interesting results - none
	The initrd.img is in / on this installation but I amended yaboot
	assuming that it was in /boot and managed get my production
	system into an unbootable state. However, mounting the partition
	in the new install allowed me to find initrd.img, update yaboot,
	and get my system back ;)  I'm in danger of becoming a geek -
	eek ;)

	I lost network connectivity because eth0 was taken over by
	ip1394 but amending /etc/network/interfaces cured the problem.
	From dmesg:
	ip1394: eth0: IEEE-1394 IPv4 over 1394 Ethernet (fw-host0)
	eth1: Sun GEM (PCI) 10/100/1000BaseT Ethernet 00:30:65:7b:b0:7a
	Interesting that on the new install, the SunGem is eth0

	On the production system on starting kde I've now got:
	"Sound server informational message:
	Error while initializing the sound driver:
	SNDCTL_DSP_SETFMT failed - Invalid argument
	The sound server will continue, using the null output device."
	However, xmms seems to play CD's fine (using the OSS Driver and
	Again the new install doesn't produce the same error.

	I also get a fatal error message on bootup saying something like
	"no printer module available" but as printing is via the network
	(using cups), it is not a problem. Again not on new install.

	It may be too early to judge but the new kernel is working fine
	and will enable me to add functionally that I haven't as yet
	attained with 2.4.23

	It is also very satisfactory to be able to use a stock kernel
	rather than having to compile ;)

	So thanks a bunch to all you developers and maintainers for your
	excellent work!




strategies for business

Reply to: