[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X problem ibook 2.2

On 06/04/04, Mathieu Segaud (matt@minas-morgul.org) wrote:
> Kiko Piris <debian@pirispons.net> writes:
> > On 05/04/2004 at 18:05, Rory Campbell-Lange wrote:
> >
> >> My kernel and modules installed from a fresh (beta3) install don't
> >> appear to have the uninorth-agp module.
> >
> > uninorth-agp is from 2.6. If you use 2.4, IIRC, you only need
> > agpgart (and radeon, of course).
> but he'll have to be sure agpgart is loaded _before_ radeon....

Still can't get it to work!

lsmod doesn't show agpart or radeon. I then do 'insmod agpart' and then
'insmod radeon'. Now it shows:

    Module                  Size  Used by    Not tainted
    radeon                116084   0  (unused)
    agpgart                18108   1 
    af_packet              15112   0  (autoclean)
    ide-scsi               11052   0 
    lp                      7388   0  (autoclean)
    parport                28900   0  (autoclean) [lp]

XFree86 Version (Debian 4.3.0-7 20040317193332 branden@cairhien.lab.dotat.at)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.6.1-rc1-ben1 ppc [ELF] 
Build Date: 17 March 2004
	Before reporting problems, check http://www.XFree86.Org/
	to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.4.25-powerpc (root@pegasos2) (version gcc 3.3.3 (Debian 20040306)) #1 ven mar 19 19:29:26 CET 2004 
(II) Loading /usr/X11R6/lib/modules/libi2c.a
(II) Module i2c: vendor="The XFree86 Project"
	compiled for, module version = 1.2.0
	ABI class: XFree86 Video Driver, version 0.6
(II) RADEON(0): I2C bus "DDC" initialized.
(WW) RADEON(0): Video BIOS not detected in PCI space!
(WW) RADEON(0): Attempting to read Video BIOS from legacy ISA space!
(WW) RADEON(0): Video BIOS not found!
(WW) RADEON(0): Video BIOS not detected, using default PLL parameters!
(II) RADEON(0): [drm] created "radeon" driver at busid "PCI:0:16:0"
(II) RADEON(0): [drm] added 8192 byte SAREA at 0xeb2b4000
(II) RADEON(0): [drm] mapped SAREA 0xeb2b4000 to 0x3001b000
(II) RADEON(0): [drm] framebuffer handle = 0x98000000
(II) RADEON(0): [drm] added 1 reserved context for kernel
(II) RADEON(0): [agp] Mode 0x07000201 [AGP 0x106b/0x0027; Card 0x1002/0x4c57]
(II) RADEON(0): [agp] 8192 kB allocated with handle 0xed2b8000
(II) RADEON(0): [agp] ring handle = 0x00000000
(EE) RADEON(0): [agp] Could not map ring
(WW) RADEON(0): [agp] AGP failed to initialize -- falling back to PCI mode.
(WW) RADEON(0): [agp] If this is an AGP card, you may want to make sure the agpgart
kernel module is loaded before the radeon kernel module.

Rory Campbell-Lange 

Reply to: