[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Rev A iMac Configuration update

> > I tried setserail, pppconfig, pon.
> > pon never worked, but after setting the modem to tty00 so minicom can
> > see it pon now complains that it has an
> > "unrecognized option '/dev/tty00'.
> > Note that ttyS0 never worked - although it seems it should!
> >
> > Any ideas? I spent a full day doing battle with man pages and docs
> > trying to get the modem to work.
> The driver has always printed out names that don't match the real
> device nodes in /dev. It prints out tty00, but that is really
> /dev/ttyS0. Did you try ttyS0 after loading the macserial module?

More to the point, the driver might print 'modem' for tty00 just because
that's usually been the modem port, or because old Powerbooks had the
modem (a real one) on this port.

Check that you have a real modem, not a controllerless modem (HCF,

> Also, I'm pretty sure that setserial has never worked on Mac style
> serial ports.

Switching speeds and such should have worked AFAIK.


Reply to: