[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Rev A iMac Configuration update

On Mon, Apr 05, 2004 at 01:04:33PM +0100, Dave Turner wrote:
> 2) no modem
> what a pain! 
> I did "modprobe macserial" which told me that the modem is on tty00.
> I installed minicom so I could confirm if the modem was being seen. It
> is. 
> I tried setserail, pppconfig, pon.
> pon never worked, but after setting the modem to tty00 so minicom can
> see it pon now complains that it has an 
> "unrecognized option '/dev/tty00'.
> Note that ttyS0 never worked - although it seems it should!
> Any ideas? I spent a full day doing battle with man pages and docs
> trying to get the modem to work.

The driver has always printed out names that don't match the real
device nodes in /dev. It prints out tty00, but that is really
/dev/ttyS0. Did you try ttyS0 after loading the macserial module?

Also, I'm pretty sure that setserial has never worked on Mac style
serial ports.

	Brad Boyer

Reply to: