[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can I Install AND boot a new Kernel on an OldWorld PMac?


1) Please post a report on your experiences when you get things working.
 I have the same problem, and I'm sure others out there do too.

2) Have you tried just using "BootX" for all your booting needs?  It
works with no PRAM changes and allows you easy access to MacOS (indeed,
you can't *avoid* accessing MacOS!)  Theoretically, all you need is to
have a copy of the kernel you want to use and the corresponding initrd
image (if any) in the system folder of your MacOS partition.  For
multiple kernels you may have to do something in your Linux-side "/boot"
directory -- I'm not sure.  It's hitting a fly with a sledge-hammer, but
it might do what you need.



christian funk wrote:
> I'm desperately trying to get oldworld powermacs to boot different
> kernels (official images or custom). Yes plural, since I have several
> oldworlds and am not sure exactly which kernels I will need.
> Can someone point me to a definitive HOWTO or thread in a mailing list?
> If not, any feedback on the below is very very welcome:
> My test setup is a PowerMac 7500 with a 604 CPU (from a 7600) and two
> SCSI HDs (/dev/sda is linux only (ext2 with 4 partitions), dev/sdb is
> MocOS 9.1 (HFS)).
> The first problem is that quik seems to work fine only after a fresh
> install. Installing Debian 3.0rev2 (2.2.20-pmac kernel) using BootX is
> simple, and the installer seems to set up quik and quik.config so that
> the machine will boot directly into linux (I can even disconnect the
> MacOS SCSI HD /sdb and it will still boot!). This is exactly what I
> want. However, this only works as long as the machine is not booted
> into MacOS by zapping the PRAM. After zapping the PRAM only booting
> from BootX works. Executing quik then has no effect (probably normal,
> since quik leaves the nvram untouched, right?). Installing a fresh
> Debian system enables to boot back into linux directly. Is there
> another way to fix the nvram and/or pram after zapping it, so I can
> boot directly to linux?
> The second problem is installing a new kernel image (2.4.18-powermac)
> with dselect. dselects prompts you to execute quikconfig. If you do,
> then quikconfig writes a new quik.confg, that looks quite different
> from the original after a fresh install, and executes quik with it. The
> new quik.conf looks wrong to me: it sets image=/boot/vmlinux, but that
> file does not exist. The original install sets it to
> image=/boot/vmlinux-2.2.20-pmac. Changing quik.conf by hand and
> executing quik does not seem to solve the problem. I've tried every
> combination I can think of: original style and new style with the
> different vmlinux and vmlinux-2.4.18-powermac arguments. Nothing does
> the trick. What seems strange, is that the original install process
> writes a different quik.conf as quikconig. What writes the quik.config
> during a fresh install?
> Does anyone know how to get quik to work properly?
> Christian Funk
> --
> To UNSUBSCRIBE, email to debian-powerpc-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: