[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cdrom mount problem on g4 - SOLVED

On (29/12/03 11:33), Vincent Bernat wrote:
> OoO En cette matinée pluvieuse du lundi  29 décembre 2003, vers 10:47,
> Clive Menzies <clive@clivemenzies.co.uk> disait:
> >> >  $ eject /dev/hdc
> >> >  eject: unable to open `/dev/hdc'
> >> 
> >> >  Confusing huh!
> >> 
> >> What do you get with "cat /proc/ide/hdc/settings" ?
> > name                    value           min             max
> [...]
> Well,  I  have no  idea why  this does not  work.  Try to use the SCSI
> emulation instead (boot with hdc=ide-scsi as parameter) and try "eject
> /dev/scd0".
Hi Vincent

I tried that but it didn't seem to enable scd0 - I put the boot
parameter in yaboot, which I assume is the way to do it.

However, Matheau emailed me off list suggesting it could be permissions
and although I'm sure I had tried to mount hdc as root before, it now
seems to work and it is also playing CD's in XMMS ;)

One slight confusion I had is that I've added myself to the group
"disk" but although "disk" and "root" have exactly the same permissions,
"rw", I could't mount or eject the disk but root could.  However, 
rebooting seemed to cure it (reminiscent of Windoze ;) In retrospect,
logging out and back in, may have achieved the same result.

Nevertheless, the main reason for upgrading to sid and ben's kernel was 
to be able to play CD's which I couldn't seem to accomplish in woody -
so another piece in the jigsaw falls into place ;)

The next issue is a strange intermittent whistle through the speakers
for which I may need to return to the list for help.  Meanwhile, I can
enjoy music from my CD's as well as off our music server ;)

So thanks to everyone who helped including Matt and Vincent. This list
and debian-user are so great ;)  I've learned so much from you all -
Happy New Year!



strategies for business

Reply to: