[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: fftw3: Patch for powerpc build failure

Michel Dänzer <daenzer@debian.org> writes:

> On Thu, 2004-01-01 at 16:45, Colin Watson wrote:
> > On Thu, Jan 01, 2004 at 01:19:14PM +0000, Colin Watson wrote:
> > > On Mon, Dec 29, 2003 at 12:32:34PM -0500, Lukas Geyer wrote:
> > > > the problem with fftw3 on powerpc is that the current debian/rules
> > > > assumes that all powerpc CPUs know Altivec instructions. That is
> > > > plainly untrue (Altivec is only available in the most recent CPUs) and
> > > > leads to an illegal instruction error here. The buildd fails with sig
> > > > 11, but I suspect the reason is the same.
> No, as the signal 11 happens on Altivec machines. Which version do you
> get an illegal instruction with doing what, under what circumstances? (I
> suspect this should be another bug though)

OK, this really seems to be two different bugs. I get an illegal
instruction in "make smallcheck" on this iBook G3. The gcc version is
the most recent in sid. Should I file another FTBFS bug about this?

> > I'm cc'ing -powerpc just in case anyone has any other ideas.
> > http://bugs.debian.org/223601 has the history. I suppose I *could* just
> > upload the successful build from my laptop but I'm not very happy about
> > doing that if it's just going to fail again on the buildd next time
> > around, or if it indicates some bug which will bite programs linked
> > against fftw3 ...
> It fails the same way here as recorded in the bug history. Adding
> -mabi=altivec to build tests/bench doesn't seem to make a difference
> here (I do wonder whether all fftw3 dependants were or will be built
> with it though...). Colin, which version of gcc-3.3 are you using? I
> noticed I still have the one from testing, not from sid. I wonder which
> version the buildd used, might be worth just retrying the build without
> changes.

Please don't upload again without testing the build on a G3. I tried
to recompile the checks with -mabi=altivec, but I still get a sig 4
crash. I will try to find out where this actually comes from, but for
the moment disabling altivec might be the easiest solution.


Reply to: