[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SOLVED - Recompiling Kernel on G4 PowerMac Gigabit dual 450Mhz

On (10/12/03 19:29), Diana Galletly wrote:
> On Wed, 10 Dec 2003, Clive Menzies wrote:
> > No doubt this is my ignorance at work but I'd appreciate some guidance.
> I don't use fakeroot so I don't know whether it really works well.
> But my advice would be to su to root and try again.  Otherwise run
> a df and make sure that you haven't accidentally filled up your
> filesystem.  And if you have looking in (I think) /var/cache/apt
> would be a good place to start on the purging :-)
Thanks Diana

I'm not sure exactly how I solved it - I did use sudo to compile but the
problem persisted (space is not a problem) and so I did "make dep" before 
"make-kpkg clean" which seemed to overcome the initial errors but on the 
compile it hung on the Altivec option.  In xconfig, it wouldn't let me 
indicate Y,M or N for altivec and so I went into "make config" and input "Y" 
and the compile worked.  So I'm now running "2.4.23-pre5-ben0 #1 SMP" and 
very happy about that;)

I have sound and can hopefully get all the other bits working - thanks
Ben ;) Another bonus is that my Macally keyboard lights for
Num|Caps|Scroll lock seem to be functioning properly.  The stock kernel
made them all come on on the first lock press and stay on - weird ;)


strategies for business

Reply to: