[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: XFS and Preempt for benh?

On Wednesday 03 Dec 2003 5:21 am, Benjamin Herrenschmidt wrote:
> On Tue, 2003-12-02 at 23:41, Lee Braiden wrote:
> The 2.4 version is definitely a no-no. 2.6 went through a bunch
> of infrastructure changes to do preempt "properly" (read: without
> adding races all over the place) and still, preempt is known in
> current 2.6 to still have problems, some generic, some PPC
> specific. Using it on 2.4 is asking for real big trouble.
> Ben.

OOPs; I thought I'd already replied to this, sorry :)

I'll bear that 2.4 preempt stuff in mind. Luckily it didn't bite me in the ass 
before :)

Thanks for the warning.


Reply to: