[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

minor sound issues on iBook with 2.6.0-test11


I've compiled Ben's 2.6.0-test11 this week for the first time on my
iBook (2.3, g3 900MHz, w/ radeon M7).

I have a couple of minor issues with it. Let me explain:

1.- alsa start on boot

On system boot, alsa is started without any error; but when I try to
play any sound, no sound at all comes out from the laptop: I launch play
somefile.wav and it gives no errors at all complaining about devices or
anything, it just does not make any sound at all.

If I restart alsa (/etc/init.d/alsa restart). Everything goes fine from
then on. It plays everything without any single problem.

The last fact, makes me think that's not a mixer values problem. What do
you think it could be the problem? (please let me know if I need to post
any additional info).

This is what I have in /etc/default/alsa:

2.- speaker beep

With 2.4.*, I could use the speaker beep (it was "emulated" with
dmasound_pmac, I guess). With 2.6 it does not work. When I run beep or I
try to make the tty console to issue it's beep, no sound is played (I
don't get any error, but neither any beep).

I've tried with pcspkr compiled in the kernel or as a module (loaded or
unloaded). I also have tried it stopping alsa and loading dmasound_pmac
(with pcspkr module loaded and unloaded).

I've been unsuccessful. Does it work for anyone here?



Please do not reply to the sender address of this email; due to spam and
Windows (TM) worms, everything not comming from the list is "stored" in
/dev/null. Put menorqui in the user part to send me anything. _Although_, I
prefer replies sent to the list so that others can benefit from the discussion.

Reply to: