[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Powerbook 15" 1Ghz radeonfb/XFree86 woes

On Sun, 2003-08-17 at 19:59, Tugrul Galatali wrote:
> On Sun, 2003-08-17 at 07:46, Michel Dänzer wrote:
> > DDC detection of the panel fails - I assume this still works perfectly
> > in Mac OS? (Could be related to the radeonfb problem and smells like a
> > firmware or even hardware problem...)
> 	If its a firmware/hardware problem, 

More likely hardware, as the X radeon driver detection doesn't involve
the firmware.

> I hope you got a way to explain it to Apple in terms they understand ;)

Tough one. :\ It seems that the panel isn't wired properly, such that
DDC over the I2C bus doesn't work. I suspect Mac OS (and possibly OF as
well - does its display work? I guess so, or you'd probably have
mentioned the console not working at all :) falls back to hardcoded
values and doesn't care much.

> > Does
> > 	Option "MonitorLayout" "LVDS"
> >
> > in the radeon device section make a difference?
> 	I grabbed your XF86Config-4.radeon, added that line and uncommented the
> font path to misc so X doesn't exit on not finding the fixed font. When
> I fire up X, the LCD stays on, but there is a narrow horizontal band,
> about 5% tall 55% down from the top, which is blooming :)

But the remaining 95% look good? Not bad for not knowing much of
anything about the panel, is it? ;)

> 	When I added that line to the XF86Config-4 brew that I had last (and
> uploaded), I see the default X screen, but its tinted yellow and looks
> like its in mode line hell.

Have you tried your config with the option above, but without a custom
mode definition (with the Modes line in the display subsection though)?

Earthling Michel Dänzer   \  Debian (powerpc), XFree86 and DRI developer
Software libre enthusiast  \     http://svcs.affero.net/rm.php?r=daenzer

Reply to: