[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installed for the first time, strange problems

On Thu, 1970-01-01 at 04:59, Sam wrote:
> >>>> I just installed Debian for the first time on my Power Mac 6500.
> >>>> I put on a few packages, including the 2.4.28-powerpc woody kernel image.
> >>>> But now the strangest things are happening.
> >>>> Sometimes when I am in enlightenment it will just freeze up.  Moving the 
> >>>> mouse and pressing keys does nothing.  The transmit light on the ethernet 
> >>>> card flashes every so often, but pinging the machine from the other one 
> >>>> (two machine ethernet using crossover cable) does not work.
> >>>> And other times I get an "Oops" message for no apparent reason.  This 
> >>>> happens often during the shutdown process.
> >>>> Upon occasion after I type my login and password into xdm, the little 
> >>>> "opening session for user storm" will appear on the xconsole, and then 
> >>>> one of two strange things will happen.  Sometimes it will almost 
> >>>> instantly print the closing session for user storm message.  Other times 
> >>>> it won't seem to do anything.  The really strange part is that the "xdm" 
> >>>> processes owned by storm refuse to die, even with kill -9 from a root 
> >>>> login on tty1.  Even with a "shutdown now" and then hitting control-D to 
> >>>> start things up again.
> >>>> And, most recently, I started up, logged in, opened an Eterm, and tried 
> >>>> to use netcat.  It died with an illegal instruction.  Then I tried ssh.  
> >>>> Same.  Neither seemed to do anything before printing "Illegal 
> >>>> Instruction".
> >>>> What's going on?  What can I do?
> >>> Sounds like either a kernel or a hardware problem. The fact that most
> >>> other people don't seem to experience the same problems with the same
> >>> kernel points towards the hardware I'm afraid - might be faulty RAM or
> >>> something. Anything interesting in the kernel output?
> [snippy snippy]
> >> [as I said, I have 96MB of memory, and it just happens to be a 64MB 
> >> module and a 32MB module, ...]
> > So can you try running with one module at a time and see if the problems
> > persist?
> Today I tried taking out the 32MB, and everything was fine for a while, 
> but then I got an "Oops" message during shutdown.
> Then I tried putting the 32MB back in and taking out the 64MB, and 
> everything was fine (other than really slow) for a while, but then I got 
> an "Oops" message.
> The really strange problems are rare, so it probably doesn't mean much 
> that they didn't happen during the brief periods I was running with only 
> one module.
> Can assume it is not the RAM and move on to investigating other causes?

I guess so.

> Have we gotten to the point where I should copy all the "Oops" messages 
> from the logs and paste them into an email?

That might be interesting, but only after piping them through ksymoops.

Earthling Michel Dänzer   \  Debian (powerpc), XFree86 and DRI developer
Software libre enthusiast  \     http://svcs.affero.net/rm.php?r=daenzer

Reply to: