[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installed for the first time, strange problems

I wrote:
>> Have we gotten to the point where I should copy all the "Oops" messages
>> from the logs and paste them into an email?
The helpful Michel Dänzer (Where are you from Michel?  How do I pronounce your name?) replied:
> That might be interesting, but only after piping them through ksymoops.

Sorry to ask what is probably a silly question if you know the answer (or where exactly to find the answer) but...

OK, over the weekend I backed up everything on my linux partition, deleted all the files, and then reinstalled everything.  I copied my APT sources list and cache after the base install, so the whole process took well under 24 hours, and I was sleeping for a few of those :)  Hopefully none of the .deb files were corrupted and causing my problem, but I really didn't want to download much on a 28.8.

Since then I've had a few freezes, but of course that doesn't provide any information.  Then today I got some "Oops" messages running BitchX (which of course had been working before, and worked again after I restarted).  So I ran ksymoops on the kernel log in /var/log (I can't remember what it is called, /var/kern.log I think).  This showed that I actually got an Oops yesterday that I didn't notice.
This was the first part of the ksymoops output:
ksymoops 2.4.5 on ppc 2.4.18-powerpc.  Options used
     -V (default)
     -k /proc/ksyms (default)
     -l /proc/modules (default)
     -o /lib/modules/2.4.18-powerpc/ (default)
     -m /boot/System.map-2.4.18-powerpc (default)

Warning: You did not tell me where to find symbol information.  I will
assume that the log matches the kernel and modules that are running
right now and I'll use the default options above for symbol resolution.
If the current kernel and/or modules do not match the log, you can get
more accurate output by telling me the kernel version and where to find
map, modules, ksyms etc.  ksymoops -h explains the options.

Warning (compare_maps): mismatch on symbol xchg_u32  , ksyms_base says c000bb20, System.map says c0006830.  Ignoring ksyms_base entry
Warning (compare_maps): mismatch on symbol packet_socks_nr  , af_packet says c792ed24, /lib/modules/2.4.18-powerpc/kernel/net/packet/af_packet.o says c792b004.  Ignoring /lib/modules/2.4.18-powerpc/kernel/net/packet/af_packet.o entry
Warning (compare_maps): mismatch on symbol sysctl_unix_max_dgram_qlen  , unix says c7826148, /lib/modules/2.4.18-powerpc/kernel/net/unix/unix.o says c7822000.  Ignoring /lib/modules/2.4.18-powerpc/kernel/net/unix/unix.o entry
Warning (compare_maps): mismatch on symbol unix_table_lock  , unix says c782614c, /lib/modules/2.4.18-powerpc/kernel/net/unix/unix.o says c7822004.  Ignoring /lib/modules/2.4.18-powerpc/kernel/net/unix/unix.o entry
Warning (compare_maps): mismatch on symbol unix_tot_inflight  , unix says c782615c, /lib/modules/2.4.18-powerpc/kernel/net/unix/unix.o says c7822014.  Ignoring /lib/modules/2.4.18-powerpc/kernel/net/unix/unix.o entry

So apparently I need to specify where to get the symbols.  Something to do with the "-k" option and /var/log/ksymoops, but beyond that I don't know.

Reply to: