[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ibook troubles after dist-upgrade

On Wed, 2003-06-04 at 12:31, Thomas Winischhofer wrote:
> Although I didn't touch any init script or /etc/fstab, during the init 
> phase for runlevel 2 many scripts complain about an empty /proc 
> directory. Indeed, after "Mounting local filesystems" it prints "/proc 
> is already mounted" - but after logging in, I see that /proc is really 
> empty. mounts states
> proc on /proc type proc (rw)
> A following mount /proc does not complain about /proc already being 
> mounted, and voila- I see the contents on ls /proc.
> In fstab, I have (like on all my x86 machines)
> proc     /proc    proc   defaults   0    0
> What the heck...?

I have

none	/proc	proc	defaults	0	0
but I don't expect that to make a difference? You may have to boot with
init=/bin/sh and start each init script manually to see what's going on.

> snooze, which worked perfectly previously, now also freezes the machine. 
> The display goes dark, and that's it. Hard lock. No syslog entries 

Has anything changed in /etc/power/pwrctl(-local)? Do you have anything
like pbbuttonsd installed?

> (and a horrible fsck on reboot, 

Can't you use a journalling filesystem?

> which I also have problems with because of a totally skrewed keymap 
> during the phase of the fsck)

As described on http://www.debian.org/ports/powerpc/keycodes, either
disable CONFIG_MAC_ADBKEYCODES in the kernel config or pass
keyboard_sends_linux_keycodes=1 as a kernel boot argument.

> Altough I use the same XF86Config-4 like before with Woody, X failed to 
> come up with sid. lspci revealed that the VGA adapter has PCI ID 0:10.0, 
> while my old XF86Config-4, which - as said - has worked over a year, 
> states 0:16.0. How is it possible that the PCI ID changed?!

It hasn't, lspci shows hex but X takes decimal.

Earthling Michel Dänzer   \  Debian (powerpc), XFree86 and DRI developer
Software libre enthusiast  \     http://svcs.affero.net/rm.php?r=daenzer

Reply to: