[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Acard AEC6280 / ATP-865


I uses the ACard 133 ATA pci card on my machine with no problems
as long as you compile your kernel with both:


That last one is crucial.  Without TUNING=y my box will always hang on the 
partition check for that card.

Here is what dmesg shows ...

AEC6280R: IDE controller on PCI bus 10 dev a0
AEC6280R: chipset revision 2
AEC6280R: not 100% native mode: will probe irqs later
AEC6280R: ROM enabled at 0x80090000
    ide2: BM-DMA at 0x0400-0x0407, BIOS settings: hde:pio, hdf:pio
    ide3: BM-DMA at 0x0408-0x040f, BIOS settings: hdg:pio, hdh:pio

In the OF device tree it looks like the following:
cd /proc/device-tree/@f2000000/ACARD,6280M@14

cd ACARD,6280M@14

hexdump device-id
0000000 0000 0009

hexdump vendor-id
0000000 0000 1191

So I would say you and I have exact same card.

BTW: If you use this card to hold your root partition then make sure you have 
built your own installer kernel that has both config settings in place 
otherwise it will not boot (I ran into this when I upgraded to YDL 3.0 but 
their kernel does not include the TUNING config option and I could therefore 
not get past the partition check.

With no extra options, after tuning it runs at UDMA(4).  I have not tried 
UDMA(5) since my drive is not rated at that speed.

Hope this helps,


On Monday 26 May 2003 02:44, Jeroen Roovers wrote:
> I've seen many questions posted on public message boards and mailing
> list archives about Linux support for the Acard AEC6280 PCI card /
> ATP-865 Ultra ATA 133 controller chip, possibly marked:
> Vendor: 0x1191
> Device ID: 0x0009
> but I haven't seen support for it expressed anywhere, particularly
> not in response to those public questions. I ran a Debian current
> (3.0r1) boot cd on a Macintosh B/W G3 last night, and neither of the
> installation kernels finds the controller or the disk attached to it.
> If I could find something like an acard.o somewhere, I could probably
> put it on an ext2 partition on an ATA Flash disk, boot from the first
> Debian cd-rom and use insmod to have the controller and disk
> recognised, and then mount a couple of Linux partitions on the hdd to
> get the Debian installation going, but for now, there seems to be no
> support at all from the 2.4.x kernel in Debian 3.0r1.
> Was this issue ever resolved?
>    Jeroen

Reply to: