[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: DRM/DRI crashes X server

On Sun, 2003-05-18 at 21:55, P Oscar Boykin wrote:
> On Sun, May 18, 2003 at 01:32:17PM +0200, Michel D?nzer wrote:
> > On Sun, 2003-05-18 at 03:04, P Oscar Boykin wrote:
> > > I *believe* I finally I have DRM and DRI set up properly.  The problem
> > > is, now if I do any GL operation, the Xserver crashes immediately.
> > > 
> > > If I run glxinfo, or glxgears, etc...  the Xserver crashes at once.
> > 
> > By crash do you mean it locks up? Or what are the symptoms?
> By crash I mean that it immediately exits my Xwindows environment and my
> display manager (in this case kdm) restarts and presents me with a log
> in screen.
> It does not lock up.

Oh, so you know what you're talking about. :)

gdm creates /var/log/XFree86.0.log.old for such cases, don't know if kdm
offers something similar.

> agpgart is loaded, as I believe is required in order to load the radeon
> DRM module.

It isn't, but it's unlikely to make a difference for a server crash.

> I might mention, that I am also the person that is reporting that XV
> will basically do the same thing: cause the Xserver to exit immediately.

Hmm, it's weird that nobody else seems to be seeing the same problems.

Does not explicitly loading any superfluous modules like GLcore, pex5,
xie, int10, drm, vbe and ddc make a difference?

Otherwise, could you either try the dri-trunk-sid packages or getting a

> The only thing I can point out is that I am using a (possibly?) unusal
> setup: a Cube, with a 22'' DFP which runs at 1600x1024 (not a 4:3
> ratio).  I don't know if any of that makes any difference, [...]

Indeed, I wouldn't expect it to, but one never knows.

Earthling Michel Dänzer   \  Debian (powerpc), XFree86 and DRI developer
Software libre enthusiast  \     http://svcs.affero.net/rm.php?r=daenzer

Reply to: