[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: installing new kernel

Jean Monnat wrote:
Dear Debian specialists,

Because of printing problems, I tried to upgrade the kernel
2.4.18-newpowermac to the kernel 2.4.20-ben10. So I downloaded it and then
tar -xvzf 2.4.20-ben10.tar.gz. I followed instructions on how to install it,
that's to say
mv vmlinux /boot
mv System.map /boot
mv modules /lib/modules/VERSION

I changed the yaboot.conf line image=/boot/vmlinux

When I reboot i get this line of message "unable to locate
/lib/modules/2.4.20-ben10..." something like that.
However, when I do uname -a, I can see that the new kernel has been loaded.

Actually, if you build a new kernel, to install the modules you should do 'make modules_install' to install the kernel modules if you want to do it manually. You may run into other probles if you don't do this.

Ok, then I tried to configure my USB printer EPSON Stylus Photo 870 with
KDE, and I can see and choose usb dev/lpO. I made a test print, but nothing
happens and I get the message "lpr executable could not be found in your
path, check your installation".
My question is: Do you think that there is any relation between the two

The problems are not related if your printer shows up as a device. The printer doesn't work, because you don't have a print spooler installed. I recommend installing the CUPS printing system. The debian package name is 'cupsys'. You can find more info on CUPS at http://www.cups.org as far as setting up your printer. Also, take a look at http://www.linuxprinting.org for information specific to your printer and possibly a PPD file if CUPS doesn't include one for your printer.

Hope that helps.


Reply to: