[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: New sleep code for ATI M6, M7 and M9

This one time, at band camp, Michel Dänzer wrote:
>On Die, 2003-03-18 at 23:26, Jamie Wilkinson wrote:
>> Yep, same here.  I downgraded from Daniel Stones' XFree86 4.3 packages la=
>> night to the official packages + Michel Daenzer's drm-trunk stuff, mainly=
> so
>> that DRI works again.
>> TiBook IV, Radeon M9.  Commenting out Load "dri" and the Section "DRI" fr=
>> XF86Config-4 sleeps and wakes up, with DRI enabled the screen doesn't com=
>> back on.  I do not know if it has woken up, though.
>I suspect it's something not directly related to X, as it Just Works(TM)
>here with or without DRI, with or without DRIReinit, with or without

Could you post your X server configuration, installed packages, and anything
else that might be relevant?  I'd like to see what differences there are
between your working configuration and mine; you say you've had sleep
working without problems on an M9-based tibook so I'm wondering what I don't
have set up here.

>> I still notice the behaviour that I can only sleep when in X once, the
>> second wakeup never succeeds.  I can reproduce this without fail.  It
>> doesn't happen in console mode -- unless I have gone into X and exited, i=
>> which case it won't wake up if it has slept once already.
>This is particularly weird.

Yeah.  There is nothing interesting being done to the machine in between
sleeps.  I can only think that the X radeon driver is doing something
incorrectly, but I have no way to know for sure.

jaq@debian.org                               http://people.debian.org/~jaq

Reply to: