[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Trying to get XFree to work on a PowerBook G3.


I recently inherited an old PowerBook G3 (Oldworld, I believe. It wouldn't
boot the CD, and BootX is working fine.) and have been installing Debian on
it. It actually went quite well, with only a minor heart-attack when
installing quick, which made the system no longer boot (and me not knowing
the reset key-combination. :-) But I got it working again and am now trying
to configure XFree, which is where I am stuck.

I have tried using the fbdev, ati and atimisc drivers both from the stable
(4.1.0) and testing (4.2.1) release. I've systematically tried different
values for all options I imagined could have an impact, like using the
kernel framebuffer interface, refresh rates for the screen and removing
driver modules. The results are pretty much all similar.

atimisc simply dies with a message of no screens found. I assume this is a
wrong driver.

ati and fbdev let the server start, but usually hang the whole machine with
a black screen. fbdev sometimes lets me kill the server after a while (with
Ctrl-Alt-Backspace), ati always hangs. fbdev also sometimes produces bands
of garbled pixels, but then it always hangs the machine.

The kernel framebuffer driver itself seems to be working fine. I've not had
any screen problems working in text mode and 'fbi' (a framebuffer image
viewer) also works without problems.

I use the following kernel arguments with BootX:

I would appreciate any hints on which direction to go from here.



Reply to: