[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X Stuck Again, Naturally


Not speaking as a guru here, just a new user with fresh experience.

I've just finished getting X going on a frankenmac 7600 last week, and your experience resonates.

When running #dpkg-reconfigure xserver-sfree86
try 'fbdev' driver instead of 'ati' driver - but wait, don't just run and make that change all by itself.

From the looks of your #lspci -vv
which looks about identical to mine, there isn't any video 'card', just the onboard video. It took me two simultaneous changes to get X going.

The first was entering 'video=controlfb into the BootX control panel at startup. I had tried 'video=offb' previously, but using that meant X did not see most of my VRAM. Your mileage may vary (see next step), and don't fear experiments. Because i'm using an older kernel, much of my VRAM is unseen anyway. [SIDE: as soon as I figure out how to update my kernel, I will.] For now I just deal with reduced colour depth (15 bit, in my case)

the second was (unsuccessfully) trying #startx
knowing that it would not succeed, and then
#more /var/log/XFree86.0.log | grep Hardware
which told me exactly how much VRAM was being seen by X. I then did some math and figured out how much bit depth my monitor resolution could get with that much VRAM.

this is the point where I ran #dpkg-reconfigure xserver-xfree86
again. i selected'fbdev' for the driver, and changed my colour depth to the highest setting that was below what i had calculated in step 2.

worked like a charm then. I have been trying since then to up teh colour depth, but I do have a fallback setup. I may be preaching to the converted, but consider BootX as a root process, and the documents say 'log all actions taken as root'.

I only got this going las week on my machine. I may not know much, and it may be wrong for your machine. Keywords you may wish to look up are "controlfb" and "offb".

Hope it helps,


> Appendix: startx errors (/var/log/XFree86.0.log)
> --------- ------ ------ ------------------------
[ snip ]
> | Fatal server error:
> | no screens found

This (above) looks SSOOOOOOO familiar to me

Syd Bauman wrote:
[ snip ]
> Later on it (where I don't know what "it" was, but it looks similar
> to dpkg-reconfigure xserver-sfree86) asked me for the brand of my
> video card. I don't know, but thought it might be ATI, so I chose
> "ati", crossed my fingers, and went on with the install.

> So, how do I find out what video card is in this thing, and what it's
> bus address, etc., is?

> Thanks for any advice.
> Appendix: lspci output
> --------- ----- ------
> | syd@yanar:~$ lspci -v
> | 00:0b.0 Host bridge: Apple Computer Inc. Bandit PowerPC host bridge (rev 03)
> |         Flags: bus master, medium devsel, latency 32
> |
> | 00:0f.0 Ethernet controller: Lite-On Communications Inc LNE100TX (rev 20)
> |         Subsystem: Netgear FA310TX
> |         Flags: bus master, medium devsel, latency 32, IRQ 25
> |         I/O ports at 0400 [disabled]
> |         Memory at 80800000 (32-bit, non-prefetchable) [disabled]
> |         Expansion ROM at 80840000 [disabled]
> |
> | 00:10.0 Class ff00: Apple Computer Inc. Grand Central I/O (rev 02)
> |         Flags: bus master, medium devsel, latency 32
> |         Memory at f3000000 (32-bit, non-prefetchable)
> |
> | syd@yanar:~$ lspci -vt
> | -[00]-+-0b.0  Apple Computer Inc. Bandit PowerPC host bridge
> |       +-0f.0  Lite-On Communications Inc LNE100TX
> |       \-10.0  Apple Computer Inc. Grand Central I/O
> | syd@yanar:~$

[ snip ]

> Appendix: X settings (/etc/X11/XF86Config-4)
> --------- - -------- -----------------------

[ snip ]

> | Section "Device"
> |       Identifier      "Generic Video Card"
> |       Driver          "ati"
> |       Option          "UseFBDev"              "true"
> | EndSection

 [ snip ]

> P.S. It's pretty obvious from the startx messages that the two lines
>      of font directories I added to the config file are not working,
>      but I'm sure that's not the source of my problem.

Reply to: