[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Altivec support in gcc

Dans un message du 18 Feb à 13:33, Michel Dänzer écrivait :
> As I understand it, the gcc vector extensions are only usable in gcc
> 3.2 (maybe 3.1), and you'd have to rebuild everything down to glibc
> with -mabi=altivec if you want to use that. 

No, you don't need to rebuild glibc to use gcc vector extensions. Indeed
-mabi=altivec "extends the current ABI with AltiVec ABI extensions.
This does not change the default ABI, instead it adds the AltiVec ABI
extensions to the current ABI." (from the glibc info page).

You also need to build the program with -maltivec.

Guillaume Morin <guillaume@morinfr.org>

                        La vie est comme un rhododendron

Reply to: