[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Initializing linux partition on install results in reboot.

On Tue, Feb 11, 2003 at 01:53:31PM -0500, Joel Schander wrote:
> I'm attempting to install Debian 3.0r1 on a Umax SuperMac 603e/200. It
> is OldWorld, so I made floppies of the boot disk (boot-floppy-hfs.img)
> and root disk (root.bin).  The former boots the box just fine, and the
> second is ejected before starting the actually install. At this point, I
> partitioned the drive as I wanted it but am not having much luck getting
> beyond this point.

What does your partition map look like?
> Attempting to Initialize and Activate Swap Partition resulted in the box
> apparently sitting idle for about three minutes, then rebooting. This
> occured a couple times, but I guess was eventually successful as I'm now
> prompted to Initialize a Linux Partition. When I attempt to do this,
> however, the box essentially does the same thing. It goes to a screen
> that says the inode tables are written OK; then it goes to a step
> "Writing superblocks and filesystem accounting information" and appears
> to sit idle for about three minutes prior to rebooting the box. I've
> tried skipping to one of the later steps -- Mount a
> Previously-Initialized Partition -- and can choose from the menu which
> of the partitions I want to mount. I do so and am told I need to mount a
> root partition, so I say OK and receive this error:  "Mount Failed:
> Invalid Argument".

To see what is happening during the partition initialization, try 
it manually. After booting and configuring the keyboard, switch 
to console 2 (Opt-F2 or Cmd-F2). At the prompt, do

mke2fs -v /dev/hda4 

(if 4 is the one you want to initialize). It should give you some 
information about what's happening, if it's a segfault or what.
For the swap partition, try

mkswap /dev/hda5

> One thing that may be important but I'm not sure is that /dev/hda2 and
> /dev/hda3 are both drivers of some sort. I've attempted deleting them as
> the box will not have multiple OSes installed, but this results in an
> error something like: "Sorry: can't delete a driver partition (yet!)".

Driver partitions won't hurt anything. Don't know why it's giving
that error message, though, maybe you have a partition map problem.

"The way the Romans made sure their bridges worked is what 
we should do with software engineers. They put the designer 
under the bridge, and then they marched over it." 
-- Lawrence Bernstein, Discover, Feb 2003

Reply to: