[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

_almost_ got suspend/resume working on iBook2.2


After speaking to Lukasz about what he had to do to get suspend/resume
working on his iBook2.2, he mentioned using a stock XFree86 server instead
of the dri-trunk one, so I removed xserver-xfree86-dri-trunk and rebooted.
When the machine came up, 'glxinfo' showed no direct rendering available
(which I would be happy to live with), and suspend/resume worked
flawlessly (I tried it 5 or 6 times). The only problem I had was that Xv
(as used by mplayer) was garbled as if every second column was garbage.
The core X11 output mode of mplayer worked OK. So, in short, everything
was Perfect.
However, then I started mplayer with the 'fbdev' output mode in X and that
garbled the screen so I rebooted.
When the machine came back up again, I was surprised to see 'glxinfo'
reporting DRI working -- and I began having the same problems with
suspend/resume as previously!
So, in short, it looks like maybe some status-saver applications in
/etc/rc6.d or somewhere else decided to modify my configuration when I
rebooted for the second time -- and now I have no idea what has changed
between the two reboots.

Does anyone have any idea? Maybe someone should send me a list of packages
to install and a list of those NOT to install? I see lots of mentioning of
suspend/resume working on this list, but noone's been able to help me
locate the problem why I can't get it to work.


   .--= ULLA! =---------------------.   `We are not here to give users what
   \     http://cactus.rulez.org     \   they want'  -- RMS, at GUADEC 2001
    `---= cactus@cactus.rulez.org =---'
Kételkedem, tehát lehet hogy vagyok.

Reply to: