[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

powermac 9500 ethernet and 2.4 booting problems

I have two questions, I hope nobody minds if I put both of them in one
email.  Both are related to a PowerMac 9500 that I'm trying to use
with woody.

First question: This beast has two ethernet cards that I haven't been
able to get working; does any know for sure whether these cards do

The first is a Scitex LANC Fast Ethernet card.  I don't know much
about this one; I understand that they are used to run SciLAN, which
is some sort of proprietary networking system that runs on top of
ethernet.  Supposedly the cards can be used as straight ethernet, but
I have no idea what driver to use (I don't even have MacOS drivers for
it).  It has SMC, Altera, and PLX chips, but I don't know which would
be relevant.

The second is an AsanteFAST 10/100 PCI Card with a Digital 21140-AF
chip.  I've tried using the tulip and old_tulip modules with 2.2.21
built from source, and ng_tulip with the Debian 2.2.20-pmac kernels.
None of these has worked.  Any ideas?

Second question: I can't boot 2.4.anything.  I've tried both Debian's
2.4.18-powermac and several iterations built from the 2.4.19 source,
and they all do the same thing.  I never get out of MacOS; after
clicking on the "Linux" button in BootX (either app or extension), the
hard drive runs for a few seconds, and the system locks up.  My
favorite theory is that the Imagine 128 video card is at fault; can
anyone verify or discount this?  I've tried all sorts of combinations
of frame buffer settings, with and without "Force video settings" and
"No video driver" in BootX.  Other than the two ethernet cards that
I've mentioned there is nothing but the onboard SCSI and ethernet in
the system (and both of those seem to work well enough).

I'm happy to provide dmesg output, config files, and anything else
that might be helpful.

Reply to: