[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Auto-repeat problem: released key not always detected

On Die, 2002-08-27 at 22:09, Michel Lanners wrote:
> On  19 Aug, this message from Vincent Lefevre echoed through cyberspace:
> > Sometimes, when I release a key after autorepeat, the system doesn't
> > notice it and autorepeat goes on until I hit another key. This has
> > already occurred in both emacs (with its own interface under X) and
> > xterm, never in the console (but I don't use it very much). This can
> > occur with either keys corresponding to simple characters (like '-')
> > or arrow keys for instance.
> > 
> > Has anyone had similar problems?
> As you have found out ;-), many people have seen this problem, and it
> has been around for a long time.
> It is most probably a problem in the ADB driver. Chris, on your iMac, is
> that with a USB keyboard? If yes, then it gets stranger...

I've seen it with USB keyboards.

> Other than that, it seems nobody has bothered enough to trace the bug to
> its root.

AFAIR it started with the new input layer, but of course it could merely
be coincidence that I never noticed it before.

The first most interesting question is probably if it really doesn't
happen in console (if so, it's probably an X server bug, otherwise
kernel); I use the console too rarely to tell.

Earthling Michel Dänzer (MrCooper)/ Debian GNU/Linux (powerpc) developer
XFree86 and DRI project member   /  CS student, Free Software enthusiast

Reply to: